Skip to content
Laskyr

Plugins · wp-polls · data as of 2026-11-04

Is WP-Polls safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.3)

As of 2026-11-04. 6 issues are on record for older versions; version 3.0.0 or newer fixes all of them that state a fix.

Latest version
3.0.3
Last updated
2026-11-04
Active installs
40,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Adds an AJAX poll system to your WordPress blog. You can also easily add a poll into your WordPress's blog post/page. — by Lester Chan

What to do

  1. Update to the latest version (3.0.3). Anything older than 3.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-polls --field=version shows what you run; wp plugin update wp-polls updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-68081 · published 2026-07-23

Cross-site scripting (XSS) in WP-Polls (2.77.3 and older)

Affected
2.77.3 and older
Fixed in
3.0.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator Cross Site Scripting (XSS) in WP-Polls <= 2.77.3 versions.

NVD CVE-2025-68081Patchstack advisory

medium 5.3 CVE-2024-13426 · published 2025-01-22

Stored cross-site scripting (XSS) in WP-Polls (2.77.2 and older)

Affected
2.77.2 and older
Fixed in
2.77.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP-Polls plugin for WordPress is vulnerable to SQL Injection via COOKIE in all versions up to, and including, 2.77.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries. Those queries are stored and results are not displayed to the attacker, which means they cannot be exploited to obtain any additional information about the database. However, a properly configured payload allows for the injection of malicious JavaScript resulting in Stored Cross-Site Scripting.

NVD CVE-2024-13426Wordfence advisoryCode change (fix)wordpress.orggithub.comgithub.comgithub.com

medium 5.3 CVE-2022-1581 · published 2022-11-21

Security issue in WP-Polls (older than 2.76.0)

Affected
older than 2.76.0
Fixed in
2.76.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.

NVD CVE-2022-1581WPScan advisoryhightechdad.com

low 3.1 CVE-2022-40130 · published 2022-11-18

Security issue in WP-Polls (2.76.0 and older)

Affected
2.76.0 and older
Fixed in
2.77.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (subscriber+) Race Condition vulnerability in WP-Polls plugin <= 2.76.0 on WordPress.

NVD CVE-2022-40130Patchstack advisorywordpress.org

critical 9.8 CVE-2015-9352 · published 2019-08-27

SQL injection in WP-Polls (older than 2.72)

Affected
older than 2.72
Fixed in
2.72
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-polls plugin before 2.72 for WordPress has SQL injection.

NVD CVE-2015-9352wordpress.org

medium 6.1 CVE-2016-10936 · published 2019-08-27

Cross-site scripting (XSS) in WP-Polls (older than 2.73.1)

Affected
older than 2.73.1
Fixed in
2.73.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-polls plugin before 2.73.1 for WordPress has XSS via the Poll bar option.

NVD CVE-2016-10936wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-Polls vulnerability status badge
<a href="https://laskyr.com/plugins/wp-polls"><img src="https://laskyr.com/plugins/wp-polls/badge.svg" alt="WP-Polls vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit