Skip to content
Laskyr

Plugins · wp-plugin-manager · data as of 2026-11-04

Is WP Plugin Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.8 or newer fixes all of them that state a fix.

Latest version
1.5.0
Last updated
2026-11-03
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WP Plugin Manager lets you disable plugins on specific pages and posts so they only load where needed. No code required. — by HasThemes

What to do

  1. Update to the latest version (1.5.0). Anything older than 1.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-plugin-manager --field=version shows what you run; wp plugin update wp-plugin-manager updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-64271 · published 2025-11-13

Cross-site request forgery (CSRF) in WP Plugin Manager (1.4.7 and older)

Affected
1.4.7 and older
Fixed in
1.4.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in HasThemes WP Plugin Manager wp-plugin-manager allows Cross Site Request Forgery.This issue affects WP Plugin Manager: from n/a through <= 1.4.7.

NVD CVE-2025-64271Patchstack advisory

medium 4.3 CVE-2023-1088 · published 2023-03-27

Cross-site request forgery (CSRF) in WP Plugin Manager (older than 1.1.8)

Affected
older than 1.1.8
Fixed in
1.1.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Plugin Manager WordPress plugin before 1.1.8 does not have CSRF check when activating plugins, which could allow attackers to make logged in admins activate arbitrary plugins present on the blog via a CSRF attack

NVD CVE-2023-1088WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Plugin Manager vulnerability status badge
<a href="https://laskyr.com/plugins/wp-plugin-manager"><img src="https://laskyr.com/plugins/wp-plugin-manager/badge.svg" alt="WP Plugin Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit