Skip to content
Laskyr

Plugins · wp-plugin-info-card · data as of 2026-11-04

Is WP Plugin Info Card safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.4.4)

As of 2026-11-04. 4 issues are on record for older versions; version 6.4.0 or newer fixes all of them that state a fix.

Latest version
6.4.4
Last updated
2026-11-01
Active installs
400+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Add beautiful, customizable cards to showcase plugins, themes, and projects from WordPress.org, GitHub repos, EDD, and third-party plugins. — by Brice Capobianco

What to do

  1. Update to the latest version (6.4.4). Anything older than 6.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-plugin-info-card --field=version shows what you run; wp plugin update wp-plugin-info-card updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-62127 · published 2026-10-08

Stored cross-site scripting (XSS) in WP Plugin Info Card (6.3.5 and older)

Affected
6.3.5 and older
Fixed in
6.4.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MediaRon LLC WP Plugin Info Card wp-plugin-info-card allows Stored XSS.This issue affects WP Plugin Info Card: from n/a through 6.3.5.

NVD CVE-2026-62127Patchstack advisory

medium 4.3 CVE-2026-2023 · published 2026-02-18

Cross-site request forgery (CSRF) in WP Plugin Info Card (6.2.0 and older)

Affected
6.2.0 and older
Fixed in
6.3.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Plugin Info Card plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 6.2.0. This is due to missing nonce validation in the ajax_save_custom_plugin() function, which is disabled by prefixing the check with 'false &&'. This makes it possible for unauthenticated attackers to create or modify custom plugin entries via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-2023Wordfence advisoryCode change (fix)github.comPlugin source

medium 6.4 CVE-2025-5116 · published 2025-06-03

Stored cross-site scripting (XSS) in WP Plugin Info Card (5.3.1 and older)

Affected
5.3.1 and older
Fixed in
5.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Plugin Info Card plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘containerid’ parameter in all versions up to, and including, 5.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This issue is due to an incomplete patch for CVE-2025-31835.

NVD CVE-2025-5116Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source

medium 6.5 CVE-2025-31835 · published 2025-04-01

Cross-site scripting (XSS) in WP Plugin Info Card (5.3.0 and older)

Affected
5.3.0 and older
Fixed in
5.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brice Capobianco WP Plugin Info Card wp-plugin-info-card allows DOM-Based XSS.This issue affects WP Plugin Info Card: from n/a through <= 5.3.0.

NVD CVE-2025-31835Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Plugin Info Card vulnerability status badge
<a href="https://laskyr.com/plugins/wp-plugin-info-card"><img src="https://laskyr.com/plugins/wp-plugin-info-card/badge.svg" alt="WP Plugin Info Card vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit