Plugins · wp-persistent-login · data as of 2026-11-04
Is Persistent Login safe? Known vulnerabilities and latest version
- Latest version
- 3.1.5
- Last updated
- 2026-10-11
- Active installs
- 5,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Persistent Login keeps users logged into your website, limits the number of active logins allowed at one time and alerts users of new devices logging … — by lukeseager
What to do
- Update to the latest version (3.1.5). Anything older than 3.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-persistent-login --field=version shows what you run; wp plugin update wp-persistent-login updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-94081 · published 2026-09-30
Cross-site scripting (XSS) in Persistent Login (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.1.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in WordPress Persistent Login <= 3.1.3 versions.
medium 6.5 CVE-2026-18752 · published 2026-09-01
SQL injection in Persistent Login (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Persistent Login plugin for WordPress is vulnerable to generic SQL Injection via 'wppl_device_id' Cookie in all versions up to, and including, 3.1.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This vulnerability is only exploitable when the plugin's Login History feature is enabled.
NVD CVE-2026-18752Wordfence advisoryCode change (fix)Plugin source
high 8.5 CVE-2026-66594 · published 2026-08-20
SQL injection in Persistent Login (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber SQL Injection in WordPress Persistent Login <= 3.1.0 versions.
Recent activity
- 2026-10-11 — latest release on wordpress.org (3.1.5).
- 2026-09-30 — Cross-site scripting (XSS) disclosed (CVE-2026-94081), fixed in 3.1.4.
- 2026-09-01 — SQL injection disclosed (CVE-2026-18752), fixed in 3.1.1.
- 2026-08-20 — SQL injection disclosed (CVE-2026-66594), fixed in 3.1.1.
Get an email when Persistent Login has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Persistent Login (wp-persistent-login) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-persistent-login (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-persistent-login"><img src="https://laskyr.com/plugins/wp-persistent-login/badge.svg" alt="Persistent Login vulnerability status"></a>