Plugins · wp-paypal · data as of 2026-11-04
Is Payment Button for PayPal safe? Known vulnerabilities and latest version
- Latest version
- 1.2.3.49
- Last updated
- 2026-10-13
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Easily accept payment in WordPress by adding a PayPal button to your website. — by Noor Alam
What to do
- Update to the latest version (1.2.3.49). Anything older than 1.2.3.42 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-paypal --field=version shows what you run; wp plugin update wp-paypal updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-16990 · published 2026-08-12
Security issue in Payment Button for PayPal (1.2.3.44 and older)
- Affected
- 1.2.3.44 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Payment Button for PayPal WordPress plugin through 1.2.3.44 does not enforce the merchant-configured price server-side and trusts a client-supplied payment amount, allowing unauthenticated attackers to create a real PayPal order against the merchant for an arbitrary lower amount.
medium 5.3 CVE-2025-14463 · published 2026-01-17
Missing authorization check in Payment Button for PayPal (1.2.3.41 and older)
- Affected
- 1.2.3.41 and older
- Fixed in
- 1.2.3.42 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Button for PayPal plugin for WordPress is vulnerable to unauthorized order creation in all versions up to, and including, 1.2.3.41. This is due to the plugin exposing a public AJAX endpoint (`wppaypalcheckout_ajax_process_order`) that processes checkout results without any authentication or server-side verification of the PayPal transaction. This makes it possible for unauthenticated attackers to create arbitrary orders on the site with any chosen transaction ID, payment status, product name, amount, or customer information via direct POST requests to the AJAX endpoint, granted they can bypass basic parameter validation. If email sending is enabled, the plugin will also trigger purchase receipt emails to any email address supplied in the request, leading to order database corruption and unauthorized outgoing emails without any real PayPal transaction taking place.
NVD CVE-2025-14463Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2024-13401 · published 2025-01-17
Stored cross-site scripting (XSS) in Payment Button for PayPal (1.2.3.35 and older)
- Affected
- 1.2.3.35 and older
- Fixed in
- 1.2.3.38 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Payment Button for PayPal plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wp_paypal_checkout' shortcode in all versions up to, and including, 1.2.3.35 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-13401Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-13 — latest release on wordpress.org (1.2.3.49).
- 2026-08-12 — Security issue disclosed (CVE-2026-16990), fix version not stated.
- 2026-01-17 — Missing authorization check disclosed (CVE-2025-14463), fixed in 1.2.3.42.
- 2025-01-17 — Stored cross-site scripting (XSS) disclosed (CVE-2024-13401), fixed in 1.2.3.38.
Get an email when Payment Button for PayPal has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Payment Button for PayPal (wp-paypal) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Noor Alam (5 tracked)
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-paypal (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-paypal"><img src="https://laskyr.com/plugins/wp-paypal/badge.svg" alt="Payment Button for PayPal vulnerability status"></a>