Plugins · wp-payment-form · data as of 2026-11-04
Is Paymattic safe? Known vulnerabilities and latest version
- Latest version
- 4.6.28
- Last updated
- 2026-10-09
- Active installs
- 3,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Create payment form, donate button to accept payments and donations. Manage subscription payment, recurring donation with customer/donor management. — by WPManageNinja
What to do
- Update to the latest version (4.6.28). Anything older than 4.6.28 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-payment-form --field=version shows what you run; wp plugin update wp-payment-form updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-108484 · published 2026-10-14
Stored cross-site scripting (XSS) in Paymattic (4.6.27 and older)
- Affected
- 4.6.27 and older
- Fixed in
- 4.6.28
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPManageNinja Best Payments Plugin for WP wp-payment-form allows Stored XSS.This issue affects Best Payments Plugin for WP: from n/a through 4.6.27.
medium 5.9 CVE-2026-42655 · published 2026-06-15
Security issue in Paymattic (4.6.19 and older)
- Affected
- 4.6.19 and older
- Fixed in
- 4.6.20
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Bypass Vulnerability in Best Payments Plugin for WP <= 4.6.19 versions.
Recent activity
- 2026-10-09 — latest release on wordpress.org (4.6.28).
- 2026-10-14 — Stored cross-site scripting (XSS) disclosed (CVE-2026-108484), fixed in 4.6.28.
- 2026-06-15 — Security issue disclosed (CVE-2026-42655), fixed in 4.6.20.
Get an email when Paymattic has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Paymattic (wp-payment-form) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPManageNinja (10 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-payment-form (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-payment-form"><img src="https://laskyr.com/plugins/wp-payment-form/badge.svg" alt="Paymattic vulnerability status"></a>