Skip to content
Laskyr

Plugins · wp-parsidate · data as of 2026-11-04

Is Parsi Date safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.5.2)

As of 2026-11-04. 2 issues are on record for older versions; version 6.4 or newer fixes all of them that state a fix.

Latest version
6.5.2
Last updated
2026-11-01
Active installs
100,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Persian date support for WordPress and WooCommerce — by Morteza Geransayeh

What to do

  1. Update to the latest version (6.5.2). Anything older than 6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-parsidate --field=version shows what you run; wp plugin update wp-parsidate updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-96836 · published 2026-09-30

Cross-site scripting (XSS) in Parsi Date (6.3 and older)

Affected
6.3 and older
Fixed in
6.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Parsi Date <= 6.3 versions.

NVD CVE-2026-96836Patchstack advisory

medium 6.1 CVE-2024-11032 · published 2024-11-26

Reflected cross-site scripting (XSS) in Parsi Date (5.1.1 and older)

Affected
5.1.1 and older
Fixed in
5.1.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Parsi Date plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 5.1.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-11032Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Parsi Date vulnerability status badge
<a href="https://laskyr.com/plugins/wp-parsidate"><img src="https://laskyr.com/plugins/wp-parsidate/badge.svg" alt="Parsi Date vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit