Plugins · wp-optimizer · data as of 2026-11-04
Is WP Optimizer safe? Known vulnerabilities and latest version
- Latest version
- 2.9.2
- Last updated
- 2026-10-21
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Improve WordPress speed and Core Web Vitals with page cache, WebP, minification, database cleanup and built-in performance diagnostics. — by sh1zen
What to do
- Update to the latest version (2.9.2). Anything older than 2.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-optimizer --field=version shows what you run; wp plugin update wp-optimizer updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-6295 · published 2026-09-19
SQL injection in WP Optimizer (2.5.0 and older)
- Affected
- 2.5.0 and older
- Fixed in
- 2.6.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Optimizer plugin for WordPress is vulnerable to SQL Injection via the 's' parameter in all versions up to and including 2.5.0. This is due to an unsafe subquery-detection branch in the Query::parse_key_compare_field() method that, when the user-supplied value matches the regex ^[(\s]*SELECT\s+, wraps the value in parentheses and embeds it directly into the SQL string without any escaping or quoting. While the normal LIKE code path correctly uses esc_sql($wpdb->esc_like(...)) and wraps the value in single quotes, this branch completely bypasses those protections. Because the attack payload (SELECT ...) contains no single quotes, WordPress's wp_magic_quotes() provides no protection. This makes it possible for authenticated attackers with administrator-level access to inject arbitrary SQL subqueries — including time-based blind payloads — that can be used to extract sensitive information from the database.
NVD CVE-2026-6295Wordfence advisoryCode change (fix)Plugin source
critical 9.6 CVE-2025-53314 · published 2025-06-27
Cross-site request forgery (CSRF) in WP Optimizer (2.5.0 and older)
- Affected
- 2.5.0 and older
- Fixed in
- 2.6.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in sh1zen WP Optimizer wp-optimizer allows SQL Injection.This issue affects WP Optimizer: from n/a through <= 2.5.0.
Recent activity
- 2026-10-21 — latest release on wordpress.org (2.9.2).
- 2026-09-19 — SQL injection disclosed (CVE-2026-6295), fixed in 2.6.5.
- 2025-06-27 — Cross-site request forgery (CSRF) disclosed (CVE-2025-53314), fixed in 2.6.5.
Get an email when WP Optimizer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Optimizer (wp-optimizer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by sh1zen (2 tracked)
Types found in this plugin: SQL injection (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-optimizer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-optimizer"><img src="https://laskyr.com/plugins/wp-optimizer/badge.svg" alt="WP Optimizer vulnerability status"></a>