Skip to content
Laskyr

Plugins · wp-optimize · data as of 2026-11-01

Is WP-Optimize safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.7.0)

As of 2026-11-01. 4 issues are on record for older versions; version 4.5.3 or newer fixes all of them that state a fix.

Latest version
4.7.0
Last updated
2026-09-21
Active installs
1+ million
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Get caching and more with this powerful cache plugin. Cache, optimize images, clean your database and minify for maximum performance. — by David Anderson / Team Updraft

What to do

  1. Update to the latest version (4.7.0). Anything older than 4.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-optimize --field=version shows what you run; wp plugin update wp-optimize updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-7252 · published 2026-05-07

Arbitrary file deletion in WP-Optimize (4.5.2 and older)

Affected
4.5.2 and older
Fixed in
4.5.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP-Optimize – Cache, Compress images, Minify & Clean database to boost page speed & performance plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the unscheduled_original_file_deletion function in all versions up to, and including, 4.5.2 This makes it possible for authenticated attackers, with author-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). This is possible because 'original-file' is a public (non-protected) meta key — it does not begin with an underscore — allowing Authors to freely create or modify it on their own attachment posts via the standard Edit Media form or the REST API.

NVD CVE-2026-7252Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2026-2712 · published 2026-04-10

Missing authorization check in WP-Optimize (4.5.0 and older)

Affected
4.5.0 and older
Fixed in
4.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP-Optimize plugin for WordPress is vulnerable to unauthorized access of functionality due to missing capability checks in the `receive_heartbeat()` function in `includes/class-wp-optimize-heartbeat.php` in all versions up to, and including, 4.5.0. This is due to the Heartbeat handler directly invoking `Updraft_Smush_Manager_Commands` methods without verifying user capabilities, nonce tokens, or the allowed commands whitelist that the normal AJAX handler (`updraft_smush_ajax`) enforces. This makes it possible for authenticated attackers, with Subscriber-level access and above, to invoke admin-only Smush operations including reading log files (`get_smush_logs`), deleting all backup images (`clean_all_backup_images`), triggering bulk image processing (`process_bulk_smush`), and modifying Smush options (`update_smush_options`).

NVD CVE-2026-2712Wordfence advisoryresearch.cleantalk.orgPlugin source

medium 4.1 CVE-2025-3951 · published 2025-06-02

SQL injection in WP-Optimize (older than 4.2.0)

Affected
older than 4.2.0
Fixed in
4.2.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The WP-Optimize WordPress plugin before 4.2.0 does not properly escape user input when checking image compression statuses, which could allow users with the administrator role to conduct SQL Injection attacks in the context of Multi-Site WordPress configurations.

NVD CVE-2025-3951WPScan advisory

medium 6.1 CVE-2023-1119 · published 2023-07-10

Cross-site scripting (XSS) in WP-Optimize (older than 3.2.13)

Affected
older than 3.2.13
Fixed in
3.2.13
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP-Optimize WordPress plugin before 3.2.13, SrbTransLatin WordPress plugin before 2.4.1 use a third-party library that removes the escaping on some HTML characters, leading to a cross-site scripting vulnerability.

NVD CVE-2023-1119WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-Optimize vulnerability status badge
<a href="https://laskyr.com/plugins/wp-optimize"><img src="https://laskyr.com/plugins/wp-optimize/badge.svg" alt="WP-Optimize vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit