Plugins · wp-multilang · data as of 2026-11-04
Is WP Multilang safe? Known vulnerabilities and latest version
- Latest version
- 2.4.34
- Last updated
- 2026-10-07
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6.20+
Multilingual plugin for WordPress. Go Multilingual in minutes with full WordPress support. Translate your site easily with this localization plugin. — by Magazine3
What to do
- Update to the latest version (2.4.34). Anything older than 2.4.32 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-multilang --field=version shows what you run; wp plugin update wp-multilang updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-15731 · published 2026-09-24
Stored cross-site scripting (XSS) in WP Multilang (2.4.31 and older)
- Affected
- 2.4.31 and older
- Fixed in
- 2.4.32 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Multilang – Translation and Multilingual Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the post content in all versions up to, and including, 2.4.31 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 7.1 CVE-2026-73342 · published 2026-08-18
Cross-site scripting (XSS) in WP Multilang (2.4.31 and older)
- Affected
- 2.4.31 and older
- Fixed in
- 2.4.32
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in WP Multilang <= 2.4.31 versions.
high 7.5 CVE-2025-49307 · published 2025-06-06
File inclusion in WP Multilang (2.4.19 and older)
- Affected
- 2.4.19 and older
- Fixed in
- 2.4.19.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Magazine3 WP Multilang wp-multilang allows PHP Local File Inclusion.This issue affects WP Multilang: from n/a through <= 2.4.19.
Recent activity
- 2026-10-07 — latest release on wordpress.org (2.4.34).
- 2026-09-24 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15731), fixed in 2.4.32.
- 2026-08-18 — Cross-site scripting (XSS) disclosed (CVE-2026-73342), fixed in 2.4.32.
- 2025-06-06 — File inclusion disclosed (CVE-2025-49307), fixed in 2.4.19.1.
Get an email when WP Multilang has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Multilang (wp-multilang) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Magazine3 (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-multilang (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-multilang"><img src="https://laskyr.com/plugins/wp-multilang/badge.svg" alt="WP Multilang vulnerability status"></a>