Skip to content
Laskyr

Plugins · wp-multi-step-checkout · data as of 2026-11-04

Is Multi-Step Checkout for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.35.1)

As of 2026-11-04. 1 issue is on record for older versions; version 2.34 or newer fixes all of them that state a fix.

Latest version
2.35.1
Last updated
2026-08-31
Active installs
8,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2.4+

Split the different sections of the default WooCommerce checkout page into multiple steps. Allow your customers a faster and easier checkout process. — by SilkyPress

What to do

  1. Update to the latest version (2.35.1). Anything older than 2.34 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-multi-step-checkout --field=version shows what you run; wp plugin update wp-multi-step-checkout updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-67542 · published 2025-12-09

Cross-site scripting (XSS) in Multi-Step Checkout for WooCommerce (2.33 and older)

Affected
2.33 and older
Fixed in
2.34
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SilkyPress Multi-Step Checkout for WooCommerce wp-multi-step-checkout allows DOM-Based XSS.This issue affects Multi-Step Checkout for WooCommerce: from n/a through <= 2.33.

NVD CVE-2025-67542Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Multi-Step Checkout for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/wp-multi-step-checkout"><img src="https://laskyr.com/plugins/wp-multi-step-checkout/badge.svg" alt="Multi-Step Checkout for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit