Skip to content
Laskyr

Plugins · wp-migrate-db · data as of 2026-11-04

Is WP Migrate Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.12)

As of 2026-11-04. 2 issues are on record for older versions; version 2.7.9 or newer fixes all of them that state a fix.

Latest version
2.7.12
Last updated
2026-10-12
Active installs
200,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Migrate your database. Export full sites including media, themes, and plugins. Find and replace content with support for serialized data. — by WP Engine

What to do

  1. Update to the latest version (2.7.12). Anything older than 2.7.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-migrate-db --field=version shows what you run; wp plugin update wp-migrate-db updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.7 CVE-2026-49043 · published 2026-06-15

Cross-site request forgery (CSRF) in WP Migrate Lite (2.7.8 and older)

Affected
2.7.8 and older
Fixed in
2.7.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in WP Migrate Lite <= 2.7.8 versions.

NVD CVE-2026-49043Patchstack advisory

medium 5.8 CVE-2025-11427 · published 2025-11-18

Server-side request forgery (SSRF) in WP Migrate Lite (2.7.6 and older)

Affected
2.7.6 and older
Fixed in
2.7.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Migrate Lite – WordPress Migration Made Easy plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in all versions up to, and including, 2.7.6 via the wpmdb_flush AJAX action. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to obtain information about internal services.

NVD CVE-2025-11427Wordfence advisoryresearch.cleantalk.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Migrate Lite vulnerability status badge
<a href="https://laskyr.com/plugins/wp-migrate-db"><img src="https://laskyr.com/plugins/wp-migrate-db/badge.svg" alt="WP Migrate Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit