Plugins · wp-meta-and-date-remover · data as of 2026-11-04
Is WP Meta and Date Remover safe? Known vulnerabilities and latest version
- Latest version
- 2.3.7
- Last updated
- 2026-05-31
- Active installs
- 80,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Remove meta author and date information from posts and pages. Hide from Humans and Search engines.SEO friendly and most advance plugin. — by prasadkirpekar
What to do
- Update to the latest version (2.3.7). Anything older than 2.3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-meta-and-date-remover --field=version shows what you run; wp plugin update wp-meta-and-date-remover updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-49051 · published 2026-05-27
Missing authorization check in WP Meta and Date Remover (2.3.6 and older)
- Affected
- 2.3.6 and older
- Fixed in
- 2.3.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Prasad Kirpekar WP Meta and Date Remover allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects WP Meta and Date Remover: from n/a through 2.3.6.
medium 5.4 CVE-2023-47836 · published 2024-12-09
Missing authorization check in WP Meta and Date Remover (2.3.0 and older)
- Affected
- 2.3.0 and older
- Fixed in
- 2.3.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in prasadkirpekar WP Meta and Date Remover wp-meta-and-date-remover allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Meta and Date Remover: from n/a through <= 2.3.0.
medium 5.4 CVE-2023-4823 · published 2023-10-31
Stored cross-site scripting (XSS) in WP Meta and Date Remover (older than 2.2.0)
- Affected
- older than 2.2.0
- Fixed in
- 2.2.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Meta and Date Remover WordPress plugin before 2.2.0 provides an AJAX endpoint for configuring the plugin settings. This endpoint has no capability checks and does not sanitize the user input, which is then later output unescaped. Allowing any authenticated users, such as subscriber change them and perform Stored Cross-Site Scripting.
Recent activity
- 2026-05-31 — latest release on wordpress.org (2.3.7).
- 2026-05-27 — Missing authorization check disclosed (CVE-2026-49051), fixed in 2.3.7.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-47836), fixed in 2.3.1.
- 2023-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2023-4823), fixed in 2.2.0.
Get an email when WP Meta and Date Remover has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Meta and Date Remover (wp-meta-and-date-remover) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by prasadkirpekar (2 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-meta-and-date-remover (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-meta-and-date-remover"><img src="https://laskyr.com/plugins/wp-meta-and-date-remover/badge.svg" alt="WP Meta and Date Remover vulnerability status"></a>