Skip to content
Laskyr

Plugins · wp-mapit · data as of 2026-11-04

Is WP MapIt safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.0 or newer fixes all of them that state a fix.

Latest version
3.1.1
Last updated
2026-05-12
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.4+

Easy to use, WordPress Map plugin based on Open Street Map and Leaflet with custom markers images, descriptions and links. — by Chandni Patel

What to do

  1. Update to the latest version (3.1.1). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-mapit --field=version shows what you run; wp plugin update wp-mapit updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-22466 · published 2026-01-22

Missing authorization check in WP MapIt (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Chandni Patel WP MapIt wp-mapit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP MapIt: from n/a through <= 3.0.3.

NVD CVE-2026-22466Patchstack advisory

medium 5.4 CVE-2023-5658 · published 2023-11-07

Stored cross-site scripting (XSS) in WP MapIt (2.7.1 and older)

Affected
2.7.1 and older
Fixed in
3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP MapIt plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wp_mapit' shortcode in all versions up to, and including, 2.7.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-5658Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP MapIt vulnerability status badge
<a href="https://laskyr.com/plugins/wp-mapit"><img src="https://laskyr.com/plugins/wp-mapit/badge.svg" alt="WP MapIt vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit