Plugins · wp-map-block · data as of 2026-11-04
Is WP Map Block safe? Known vulnerabilities and latest version
- Latest version
- 3.2.1
- Last updated
- 2026-11-02
- Active installs
- 20,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
No API key is required to launch Google Maps & OpenStreetMap. — by Tushar Imran
What to do
- Update to the latest version (3.2.1). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-map-block --field=version shows what you run; wp plugin update wp-map-block updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-19798 · published 2026-10-16
Missing authorization check in WP Map Block (3.0.0 and older)
- Affected
- 3.0.0 and older
- Fixed in
- 3.1.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Wp Map Block plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the set_status() and bulk() functions in the Maps_Controller REST controller in versions up to, and including, 3.0.0. The plugin's permission_callback (can_edit()) only verifies current_user_can('edit_posts') and performs no object-level ownership check or verification of publish-level capabilities, while the handlers pass the caller-controlled map ID directly to wp_update_post() (and wp_delete_post() in the bulk delete branch) to change post_status between publish and draft. This makes it possible for authenticated attackers, with Contributor-level access and above, to publish or unpublish (and bulk-delete) any wpmb_map post, including maps owned by administrators, which hides published maps from all public pages site-wide or forces draft maps to become publicly visible.
NVD CVE-2026-19798Wordfence advisoryCode change (fix)Plugin source
medium 4.8 CVE-2025-5194 · published 2025-06-27
Stored cross-site scripting (XSS) in WP Map Block (older than 2.0.3)
- Affected
- older than 2.0.3
- Fixed in
- 2.0.3
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WP Map Block WordPress plugin before 2.0.3 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
medium 5.4 CVE-2021-24643 · published 2021-09-27
Stored cross-site scripting (XSS) in WP Map Block (older than 1.2.3)
- Affected
- older than 1.2.3
- Fixed in
- 1.2.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The WP Map Block WordPress plugin before 1.2.3 does not escape some attributes of the WP Map Block, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Recent activity
- 2026-11-02 — latest release on wordpress.org (3.2.1).
- 2026-10-16 — Missing authorization check disclosed (CVE-2026-19798), fixed in 3.1.0.
- 2025-06-27 — Stored cross-site scripting (XSS) disclosed (CVE-2025-5194), fixed in 2.0.3.
- 2021-09-27 — Stored cross-site scripting (XSS) disclosed (CVE-2021-24643), fixed in 1.2.3.
Get an email when WP Map Block has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Map Block (wp-map-block) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-map-block (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-map-block"><img src="https://laskyr.com/plugins/wp-map-block/badge.svg" alt="WP Map Block vulnerability status"></a>