Plugins · wp-mail-logging · data as of 2026-11-01
Is WP Mail Logging safe? Known vulnerabilities and latest version
- Latest version
- 1.17.1
- Last updated
- 2026-10-14
- Active installs
- 300,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Log, view, and resend all emails sent from your WordPress site. Great for resolving email sending issues or keeping a copy for auditing. — by Syed Balkhi
What to do
- Update to the latest version (1.17.1). Anything older than 1.17.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-mail-logging --field=version shows what you run; wp plugin update wp-mail-logging updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 2.7 CVE-2026-109401 · published 2026-10-16
Information disclosure in WP Mail Logging (1.17.0 and older)
- Affected
- 1.17.0 and older
- Fixed in
- 1.17.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Mail Logging plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.17.0 via the 'email_address' parameter. This makes it possible for authenticated attackers, with administrator-level access and above, to extract complete logged mail rows belonging to other users — including recipient addresses, message subjects, full message bodies, and any URLs contained therein — whose addresses happen to match the wildcard. Exploitation requires an administrator to process a personal-data export request for the attacker's email address via the standard WordPress privacy workflow, and the attacker's address must contain a LIKE wildcard character (such as an underscore) that matches at least one other user's address in the mail log.
NVD CVE-2026-109401Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2026-1661 · published 2026-10-02
Cross-site scripting (XSS) in WP Mail Logging (older than 1.17.0)
- Affected
- older than 1.17.0
- Fixed in
- 1.17.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The WP Mail Logging WordPress plugin before 1.17.0 does not properly restrict the HTML and CSS of logged emails before rendering them in its admin log screens, allowing unauthenticated users to inject styled content and links, for example through a public contact form, that can deceive an administrator viewing the log and send their browser to an attacker-controlled page.
high 7.5 CVE-2026-2471 · published 2026-02-28
PHP object injection in WP Mail Logging (1.15.0 and older)
- Affected
- 1.15.0 and older
- Fixed in
- 1.16.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Mail Logging plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.15.0 via deserialization of untrusted input from the email log message field. This is due to the `BaseModel` class constructor calling `maybe_unserialize()` on all properties retrieved from the database without validation. This makes it possible for unauthenticated attackers to inject a PHP Object by submitting a double-serialized payload through any public-facing form that sends email (e.g., Contact Form 7). When the email is logged and subsequently viewed by an administrator, the malicious payload is deserialized into an arbitrary PHP object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.
NVD CVE-2026-2471Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2023-3081 · published 2023-07-12
Stored cross-site scripting (XSS) in WP Mail Logging (1.11.1 and older)
- Affected
- 1.11.1 and older
- Fixed in
- 1.11.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Mail Logging plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 1.11.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: An incomplete fix was released in 1.11.1.
Recent activity
- 2026-10-14 — latest release on wordpress.org (1.17.1).
- 2026-10-16 — Information disclosure disclosed (CVE-2026-109401), fixed in 1.17.1.
- 2026-10-02 — Cross-site scripting (XSS) disclosed (CVE-2026-1661), fixed in 1.17.0.
- 2026-02-28 — PHP object injection disclosed (CVE-2026-2471), fixed in 1.16.0.
Get an email when WP Mail Logging has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Mail Logging (wp-mail-logging) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-mail-logging (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-mail-logging"><img src="https://laskyr.com/plugins/wp-mail-logging/badge.svg" alt="WP Mail Logging vulnerability status"></a>