Skip to content
Laskyr

Plugins · wp-mail-gateway · data as of 2026-11-04

Is WP Mail Gateway safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.1)

As of 2026-11-04. 1 issue is on record for older versions; version 1.8.1 or newer fixes all of them that state a fix.

Latest version
1.8.1
Last updated
2026-04-25
Active installs
60+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
5.4.25 · PHP 5.6+

Send email from your Wordpress site via SMTP and other 3rd party mail gateway provider. Current it supports Amazon SES, Mailgun, Mandrill, Mailjet, Po … — by Shaharia Azam

What to do

  1. Update to the latest version (1.8.1). Anything older than 1.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-mail-gateway --field=version shows what you run; wp plugin update wp-mail-gateway updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-6963 · published 2026-05-02

Privilege escalation in WP Mail Gateway (1.8 and older)

Affected
1.8 and older
Fixed in
1.8.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Mail Gateway plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the wmg_save_provider_config AJAX action in all versions up to, and including, 1.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update SMTP settings and redirect mail which can be used for privilege escalation by triggering a password reset email and using that to access and administrator's account.

NVD CVE-2026-6963Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Mail Gateway vulnerability status badge
<a href="https://laskyr.com/plugins/wp-mail-gateway"><img src="https://laskyr.com/plugins/wp-mail-gateway/badge.svg" alt="WP Mail Gateway vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit