Plugins · wp-mail-catcher · data as of 2026-11-04
Is Mail logging & Catcher safe? Known vulnerabilities and latest version
- Latest version
- 2.3.0
- Last updated
- 2026-10-18
- Active installs
- 20,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Stop from ever losing your emails again! This fast, lightweight plugin (under 140kb in size!) is also useful for debugging or backing up your messages — by JWardee
What to do
- Update to the latest version (2.3.0). Anything older than 2.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-mail-catcher --field=version shows what you run; wp plugin update wp-mail-catcher updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-120040 · published 2026-10-31
Information disclosure in Mail logging & Catcher (2.2.0 and older)
- Affected
- 2.2.0 and older
- Fixed in
- 2.3.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Mail logging & Catcher plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.2.0 via the 'message' parameter. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract valid administrator password-reset keys from stored email logs and complete the WordPress password-reset flow to escalate privileges to administrator. Exploitation requires an administrator to have previously configured the plugin's default_view_role setting to a capability held by low-privileged users such as 'read'; on an untouched install the default of 'manage_options' restricts log access to administrators only.
NVD CVE-2026-120040Wordfence advisorygithub.comPlugin source
high 7.2 CVE-2026-93889 · published 2026-10-03
Stored cross-site scripting (XSS) in Mail logging & Catcher (2.1.12 and older)
- Affected
- 2.1.12 and older
- Fixed in
- 2.2.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Mail logging – WP Mail Catcher plugin for WordPress is vulnerable to Stored Cross-Site Scripting via PHPMailer 'wp_mail_failed' Error Message in all versions up to, and including, 2.1.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires a separately installed plugin, such as Contact Form 7, that passes unauthenticated user-controlled input into mail fields whose content PHPMailer will include in its failure error message.
NVD CVE-2026-93889Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2024-47339 · published 2024-10-06
Reflected cross-site scripting (XSS) in Mail logging & Catcher (2.1.9 and older)
- Affected
- 2.1.9 and older
- Fixed in
- 2.1.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in JWardee WP Mail Catcher wp-mail-catcher allows Reflected XSS.This issue affects WP Mail Catcher: from n/a through <= 2.1.9.
medium 4.3 CVE-2024-32099 · published 2024-04-15
Cross-site request forgery (CSRF) in Mail logging & Catcher (2.1.6 and older)
- Affected
- 2.1.6 and older
- Fixed in
- 2.1.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in James Ward WP Mail Catcher.This issue affects WP Mail Catcher: from n/a through 2.1.6.
high 7.2 CVE-2023-50844 · published 2023-12-28
SQL injection in Mail logging & Catcher (2.1.3 and older)
- Affected
- 2.1.3 and older
- Fixed in
- 2.1.4
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in James Ward Mail logging – WP Mail Catcher.This issue affects Mail logging – WP Mail Catcher: from n/a through 2.1.3.
medium 6.1 CVE-2023-3080 · published 2023-07-12
Stored cross-site scripting (XSS) in Mail logging & Catcher (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Mail Catcher plugin for WordPress is vulnerable to Stored Cross-Site Scripting via an email subject in versions up to, and including, 2.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-10-18 — latest release on wordpress.org (2.3.0).
- 2026-10-31 — Information disclosure disclosed (CVE-2026-120040), fixed in 2.3.0.
- 2026-10-03 — Stored cross-site scripting (XSS) disclosed (CVE-2026-93889), fixed in 2.2.0.
- 2024-10-06 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-47339), fixed in 2.1.10.
Get an email when Mail logging & Catcher has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mail logging & Catcher (wp-mail-catcher) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-mail-catcher (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-mail-catcher"><img src="https://laskyr.com/plugins/wp-mail-catcher/badge.svg" alt="Mail logging & Catcher vulnerability status"></a>