Plugins · wp-jquery-lightbox · data as of 2026-11-04
Is LightPress Lightbox safe? Known vulnerabilities and latest version
- Latest version
- 2.3.5
- Last updated
- 2026-03-25
- Active installs
- 40,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.0+
Simple, lightweight lightbox plugin for WordPress. Formerly the WP JQuery Lightbox. — by Firelight
What to do
- Update to the latest version (2.3.5). Anything older than 2.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-jquery-lightbox --field=version shows what you run; wp plugin update wp-jquery-lightbox updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-4379 · published 2026-04-08
Stored cross-site scripting (XSS) in LightPress Lightbox (2.3.4 and older)
- Affected
- 2.3.4 and older
- Fixed in
- 2.3.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The LightPress Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `group` attribute in the `[gallery]` shortcode in all versions up to, and including, 2.3.4. This is due to the plugin modifying gallery shortcode output to include the `group` attribute value without proper escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-4379Wordfence advisoryCode change (fix)Plugin source
medium 6.8 CVE-2025-3649 · published 2025-05-12
Stored cross-site scripting (XSS) in LightPress Lightbox (older than 2.3.4)
- Affected
- older than 2.3.4
- Fixed in
- 2.3.4
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The LightPress Lightbox WordPress plugin before 2.3.4 does not check download links point to valid, non-Javascript URLs, allowing users with at least the contributor role to conduct Stored XSS attacks.
medium 5.4 CVE-2024-5425 · published 2024-06-07
Stored cross-site scripting (XSS) in LightPress Lightbox (1.5.4 and older)
- Affected
- 1.5.4 and older
- Fixed in
- 1.5.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP jQuery Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘title’ attribute in all versions up to, and including, 1.5.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-5425Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source
Recent activity
- 2026-03-25 — latest release on wordpress.org (2.3.5).
- 2026-04-08 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4379), fixed in 2.3.5.
- 2025-05-12 — Stored cross-site scripting (XSS) disclosed (CVE-2025-3649), fixed in 2.3.4.
- 2024-06-07 — Stored cross-site scripting (XSS) disclosed (CVE-2024-5425), fixed in 1.5.5.
Get an email when LightPress Lightbox has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for LightPress Lightbox (wp-jquery-lightbox) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Firelight (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-jquery-lightbox (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-jquery-lightbox"><img src="https://laskyr.com/plugins/wp-jquery-lightbox/badge.svg" alt="LightPress Lightbox vulnerability status"></a>