Skip to content
Laskyr

Plugins · wp-job-manager · data as of 2026-11-04

Is WP Job Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.9)

As of 2026-11-04. 4 issues are on record for older versions; version 2.4.1 or newer fixes all of them that state a fix.

Latest version
2.4.9
Last updated
2026-10-28
Active installs
70,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create a careers page for your company website, or build a public job board for your community. — by Automattic

What to do

  1. Update to the latest version (2.4.9). Anything older than 2.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-job-manager --field=version shows what you run; wp plugin update wp-job-manager updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-25404 · published 2026-02-19

Missing authorization check in WP Job Manager (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Automattic WP Job Manager wp-job-manager allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Job Manager: from n/a through <= 2.4.0.

NVD CVE-2026-25404Patchstack advisory

medium 5.4 CVE-2023-52212 · published 2026-01-05

Cross-site request forgery (CSRF) in WP Job Manager (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.1.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Automattic WP Job Manager allows Cross Site Request Forgery.This issue affects WP Job Manager: from n/a through 2.0.0.

NVD CVE-2023-52212Patchstack advisory

medium 5.3 CVE-2024-34549 · published 2024-05-14

Information disclosure in WP Job Manager (2.2.2 and older)

Affected
2.2.2 and older
Fixed in
2.3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Automattic WP Job Manager.This issue affects WP Job Manager: from n/a through 2.2.2.

NVD CVE-2024-34549Patchstack advisory

medium 5.3 CVE-2023-52211 · published 2024-04-12

Missing authorization check in WP Job Manager (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.1.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Automattic WP Job Manager.This issue affects WP Job Manager: from n/a through 2.0.0.

NVD CVE-2023-52211Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Job Manager vulnerability status badge
<a href="https://laskyr.com/plugins/wp-job-manager"><img src="https://laskyr.com/plugins/wp-job-manager/badge.svg" alt="WP Job Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit