Skip to content
Laskyr

Plugins · wp-health · data as of 2026-11-04

Is WP Umbrella safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.28.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.27.0 or newer fixes all of them that state a fix.

Latest version
2.28.1
Last updated
2026-10-30
Active installs
90,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Everything you need to sell WordPress maintenance and manage multiple sites effortlessly: backup, update, uptime monitoring, and security. — by WP Umbrella - Backup WordPress

What to do

  1. Update to the latest version (2.28.1). Anything older than 2.27.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-health --field=version shows what you run; wp plugin update wp-health updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-66642 · published 2026-08-10

Cross-site request forgery (CSRF) in WP Umbrella (2.24.2 to 2.26.2)

Affected
2.24.2 to 2.26.2
Fixed in
2.27.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WP Umbrella allows Cross Site Request Forgery. This issue affects WP Umbrella: from 2.24.2 through 2.26.2.

NVD CVE-2026-66642Patchstack advisorywp-umbrella.com

critical 9.8 CVE-2024-12209 · published 2024-12-08

File inclusion in WP Umbrella (2.17.0 and older)

Affected
2.17.0 and older
Fixed in
v2.17.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Umbrella: Update Backup Restore & Monitoring plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.17.0 via the 'filename' parameter of the 'umbrella-restore' action. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

NVD CVE-2024-12209Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Umbrella vulnerability status badge
<a href="https://laskyr.com/plugins/wp-health"><img src="https://laskyr.com/plugins/wp-health/badge.svg" alt="WP Umbrella vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit