Plugins · wp-graphql · data as of 2026-11-04
Is WPGraphQL safe? Known vulnerabilities and latest version
- Latest version
- 2.26.1
- Last updated
- 2026-11-03
- Active installs
- 30,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
WPGraphQL adds a flexible and powerful GraphQL API to WordPress, enabling efficient querying and interaction with your site's data. — by Jason Bahl
What to do
- Update to the latest version (2.26.1). Anything older than 2.24.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-graphql --field=version shows what you run; wp plugin update wp-graphql updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-109703 · published 2026-10-13
Missing authorization check in WPGraphQL (2.23.1 and older)
- Affected
- 2.23.1 and older
- Fixed in
- 2.24.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WPGraphQL WPGraphQL wp-graphql allows Retrieve Embedded Sensitive Data.This issue affects WPGraphQL: from n/a through 2.23.1.
high 7.5 CVE-2026-40762 · published 2026-06-15
SQL injection in WPGraphQL (older than 2.11.1)
- Affected
- older than 2.11.1
- Fixed in
- 2.11.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated SQL Injection in WPGraphQL < 2.11.1 versions.
medium 5.4 CVE-2025-68604 · published 2026-05-07
Cross-site request forgery (CSRF) in WPGraphQL (2.5.3 and older)
- Affected
- 2.5.3 and older
- Fixed in
- 2.5.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in WPGraphQL allows Cross Site Request Forgery. This issue affects WPGraphQL: from n/a through 2.5.3.
medium 6.5 CVE-2023-23684 · published 2023-11-13
Server-side request forgery (SSRF) in WPGraphQL (1.14.5 and older)
- Affected
- 1.14.5 and older
- Fixed in
- 1.14.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.
medium 5.3 CVE-2019-25060 · published 2022-05-09
Missing authorization check in WPGraphQL (older than 0.3.5)
- Affected
- older than 0.3.5
- Fixed in
- 0.3.5
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
Recent activity
- 2026-11-03 — latest release on wordpress.org (2.26.1).
- 2026-10-13 — Missing authorization check disclosed (CVE-2026-109703), fixed in 2.24.0.
- 2026-06-15 — SQL injection disclosed (CVE-2026-40762), fixed in 2.11.1.
- 2026-05-07 — Cross-site request forgery (CSRF) disclosed (CVE-2025-68604), fixed in 2.5.4.
Get an email when WPGraphQL has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPGraphQL (wp-graphql) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · SQL injection (1) · Cross-site request forgery (CSRF) (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-graphql (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-graphql"><img src="https://laskyr.com/plugins/wp-graphql/badge.svg" alt="WPGraphQL vulnerability status"></a>