Plugins · wp-front-end-profile · data as of 2026-11-04
Is WP Frontend Profile safe? Known vulnerabilities and latest version
- Latest version
- 1.3.9
- Last updated
- 2026-02-21
- Active installs
- 100+
- Known issues on record
- 5
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 5.2.17+
WP Frontend Profile allows users to edit/view their profile and register/login without going into the dashboard to do so. — by Glowlogix
What to do
- There is no fixed version yet. If you can live without WP Frontend Profile for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wp-front-end-profile --field=version shows what you run; wp plugin update wp-front-end-profile updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 affects latest 1.3.9 CVE-2026-39688 · published 2026-04-08
Missing authorization check in WP Frontend Profile (1.3.9 and older)
- Affected
- 1.3.9 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Glowlogix WP Frontend Profile wp-front-end-profile allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Frontend Profile: from n/a through <= 1.3.9.
medium 4.3 CVE-2026-1644 · published 2026-03-07
Cross-site request forgery (CSRF) in WP Frontend Profile (1.3.8 and older)
- Affected
- 1.3.8 and older
- Fixed in
- 1.3.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Frontend Profile plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3.8. This is due to missing nonce validation on the 'update_action' function. This makes it possible for unauthenticated attackers to approve or reject user account registrations via a forged request granted they can trick an administrator into performing an action such as clicking on a link.
NVD CVE-2026-1644Wordfence advisoryCode change (fix)Plugin source
critical 9.8 CVE-2023-51483 · published 2024-05-17
Privilege escalation in WP Frontend Profile (1.3.1 and older)
- Affected
- 1.3.1 and older
- Fixed in
- 1.3.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Privilege Management vulnerability in Glowlogix WP Frontend Profile allows Privilege Escalation.This issue affects WP Frontend Profile: from n/a through 1.3.1.
medium 6.1 CVE-2019-15110 · published 2019-08-21
Cross-site scripting (XSS) in WP Frontend Profile (older than 0.2.2)
- Affected
- older than 0.2.2
- Fixed in
- 0.2.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The wp-front-end-profile plugin before 0.2.2 for WordPress has XSS.
critical 9.8 CVE-2019-15111 · published 2019-08-21
Privilege escalation in WP Frontend Profile (older than 0.2.2)
- Affected
- older than 0.2.2
- Fixed in
- 0.2.2
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The wp-front-end-profile plugin before 0.2.2 for WordPress has a privilege escalation issue.
Recent activity
- 2026-02-21 — latest release on wordpress.org (1.3.9).
- 2026-04-08 — Missing authorization check disclosed (CVE-2026-39688), no fix listed yet.
- 2026-03-07 — Cross-site request forgery (CSRF) disclosed (CVE-2026-1644), fixed in 1.3.9.
- 2024-05-17 — Privilege escalation disclosed (CVE-2023-51483), fixed in 1.3.2.
Get an email when WP Frontend Profile has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Frontend Profile (wp-front-end-profile) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (2) · Missing authorization (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-front-end-profile (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-front-end-profile"><img src="https://laskyr.com/plugins/wp-front-end-profile/badge.svg" alt="WP Frontend Profile vulnerability status"></a>