Skip to content
Laskyr

Plugins · wp-facebook-reviews · data as of 2026-11-04

Is WP Review Slider safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (15.3)

As of 2026-11-04. 5 issues are on record for older versions; version 14.0 or newer fixes all of them that state a fix.

Latest version
15.3
Last updated
2026-10-16
Active installs
6,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Facebook reviews & X (Twitter) posts in a WordPress review slider or grid. Official Facebook API + X API v2. Saved locally for fast social proof. — by jgwhite33

What to do

  1. Update to the latest version (15.3). Anything older than 14.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-facebook-reviews --field=version shows what you run; wp plugin update wp-facebook-reviews updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-32491 · published 2026-03-25

Stored cross-site scripting (XSS) in WP Review Slider (13.9 and older)

Affected
13.9 and older
Fixed in
14.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in jgwhite33 WP Review Slider wp-facebook-reviews allows Stored XSS.This issue affects WP Review Slider: from n/a through <= 13.9.

NVD CVE-2026-32491Patchstack advisory

medium 4.8 CVE-2023-51685 · published 2024-02-01

Stored cross-site scripting (XSS) in WP Review Slider (12.7 and older)

Affected
12.7 and older
Fixed in
12.8
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LJ Apps WP Review Slider allows Stored XSS.This issue affects WP Review Slider: from n/a through 12.7.

NVD CVE-2023-51685Patchstack advisory

medium 4.8 CVE-2023-6456 · published 2024-01-22

Stored cross-site scripting (XSS) in WP Review Slider (older than 13.0)

Affected
older than 13.0
Fixed in
13.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Review Slider WordPress plugin before 13.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2023-6456WPScan advisory

high 8.8 CVE-2023-0260 · published 2023-02-13

SQL injection in WP Review Slider (older than 12.2)

Affected
older than 12.2
Fixed in
12.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Review Slider WordPress plugin before 12.2 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as subscriber.

NVD CVE-2023-0260WPScan advisory

high 7.2 CVE-2022-0383 · published 2022-02-28

SQL injection in WP Review Slider (older than 11.0)

Affected
older than 11.0
Fixed in
11.0
Access needed (per CVSS)
Needs an admin-level account
Range from
advisory text · score by NVD
Details from the advisory

The WP Review Slider WordPress plugin before 11.0 does not sanitise and escape the pid parameter when copying a Twitter source, which could allow a high privilege users to perform SQL Injections attacks

NVD CVE-2022-0383WPScan advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Review Slider vulnerability status badge
<a href="https://laskyr.com/plugins/wp-facebook-reviews"><img src="https://laskyr.com/plugins/wp-facebook-reviews/badge.svg" alt="WP Review Slider vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit