Plugins · wp-express-checkout · data as of 2026-11-04
Is WP Express Checkout (Fast Payments via PayPal… safe? Known vulnerabilities and latest version
- Latest version
- 2.5.4
- Last updated
- 2026-09-28
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Allows you to accept fast and secure payments for products and services via a payment popup window, supporting both the new PayPal and Stripe Checkout … — by mra13 / Team Tips and Tricks HQ
What to do
- Update to the latest version (2.5.4). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-express-checkout --field=version shows what you run; wp plugin update wp-express-checkout updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-96818 · published 2026-09-30
Missing authorization check in WP Express Checkout (Fast Payments via PayPal… (2.4.9 and older)
- Affected
- 2.4.9 and older
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in WP Express Checkout (Accept PayPal Payments) <= 2.4.9 versions.
high 7.5 CVE-2024-30527 · published 2024-05-17
Security issue in WP Express Checkout (Fast Payments via PayPal… (2.3.7 and older)
- Affected
- 2.3.7 and older
- Fixed in
- 2.3.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Validation of Specified Quantity in Input vulnerability in Tips and Tricks HQ WP Express Checkout (Accept PayPal Payments) allows Manipulating Hidden Fields.This issue affects WP Express Checkout (Accept PayPal Payments): from n/a through 2.3.7.
medium 4.8 CVE-2023-1469 · published 2023-03-17
Stored cross-site scripting (XSS) in WP Express Checkout (Fast Payments via PayPal… (2.2.8 only)
- Affected
- 2.2.8 only
- Fixed in
- 2.2.9 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Express Checkout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘pec_coupon[code]’ parameter in versions up to, and including, 2.2.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with administrator-level access to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: This can potentially be exploited by lower-privileged users if the `Admin Dashboard Access Permission` setting it set for those users to access the dashboard.
Recent activity
- 2026-09-28 — latest release on wordpress.org (2.5.4).
- 2026-09-30 — Missing authorization check disclosed (CVE-2026-96818), fixed in 2.5.0.
- 2024-05-17 — Security issue disclosed (CVE-2024-30527), fixed in 2.3.8.
- 2023-03-17 — Stored cross-site scripting (XSS) disclosed (CVE-2023-1469), fixed in 2.2.9.
Get an email when WP Express Checkout (Fast Payments via PayPal… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Express Checkout (Fast Payments via PayPal… (wp-express-checkout) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by mra13 / Team Tips and Tricks HQ (4 tracked)
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-express-checkout (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-express-checkout"><img src="https://laskyr.com/plugins/wp-express-checkout/badge.svg" alt="WP Express Checkout (Fast Payments via PayPal… vulnerability status"></a>