Skip to content
Laskyr

Plugins · wp-event-aggregator · data as of 2026-11-04

Is WP Event Aggregator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.4)

As of 2026-11-04. 4 issues are on record for older versions; version 1.8.8 or newer fixes all of them that state a fix.

Latest version
1.9.4
Last updated
2026-10-29
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Xylus WP Event Aggregator: Easy way to import Eventbrite events, MeetUp events, Social site Events into your WordPress Event Calendar. — by Xylus Themes

What to do

  1. Update to the latest version (1.9.4). Anything older than 1.8.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-event-aggregator --field=version shows what you run; wp plugin update wp-event-aggregator updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1941 · published 2026-02-18

Stored cross-site scripting (XSS) in WP Event Aggregator (1.8.7 and older)

Affected
1.8.7 and older
Fixed in
1.8.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Event Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wp_events' shortcode in all versions up to, and including, 1.8.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1941Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2025-24700 · published 2025-02-14

Reflected cross-site scripting (XSS) in WP Event Aggregator (1.8.2 and older)

Affected
1.8.2 and older
Fixed in
1.8.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Xylus Themes WP Event Aggregator wp-event-aggregator allows Reflected XSS.This issue affects WP Event Aggregator: from n/a through <= 1.8.2.

NVD CVE-2025-24700Patchstack advisory

medium 6.5 CVE-2024-38703 · published 2024-07-20

Stored cross-site scripting (XSS) in WP Event Aggregator (1.7.9 and older)

Affected
1.7.9 and older
Fixed in
1.8.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Xylus Themes WP Event Aggregator allows Stored XSS.This issue affects WP Event Aggregator: from n/a through 1.7.9.

NVD CVE-2024-38703Patchstack advisory

medium 4.3 CVE-2024-31371 · published 2024-04-12

Cross-site request forgery (CSRF) in WP Event Aggregator (1.7.6 and older)

Affected
1.7.6 and older
Fixed in
1.7.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Xylus Themes WP Event Aggregator.This issue affects WP Event Aggregator: from n/a through 1.7.6.

NVD CVE-2024-31371Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Event Aggregator vulnerability status badge
<a href="https://laskyr.com/plugins/wp-event-aggregator"><img src="https://laskyr.com/plugins/wp-event-aggregator/badge.svg" alt="WP Event Aggregator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit