Plugins · wp-duplicate-page · data as of 2026-11-04
Is WP Duplicate Page safe? Known vulnerabilities and latest version
- Latest version
- 1.8.7
- Last updated
- 2026-09-08
- Active installs
- 60,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.4+
Duplicate pages, posts, and custom post types with one click. Create templates, preserve content states, and speed up workflows. — by Ninja Team
What to do
- Update to the latest version (1.8.7). Anything older than 1.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-duplicate-page --field=version shows what you run; wp plugin update wp-duplicate-page updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2025-14001 · published 2026-01-13
Missing authorization check in WP Duplicate Page (1.8 and older)
- Affected
- 1.8 and older
- Fixed in
- 1.8.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Duplicate Page plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on the 'duplicateBulkHandle' and 'duplicateBulkHandleHPOS' functions in all versions up to, and including, 1.8. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate arbitrary posts, pages, and WooCommerce HPOS orders even when their role is explicitly excluded from the plugin's "Allowed User Roles" setting, potentially exposing sensitive information and allowing duplicate fulfillment of WooCommerce orders.
NVD CVE-2025-14001Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-12481 · published 2025-11-18
Missing authorization check in WP Duplicate Page (1.7 and older)
- Affected
- 1.7 and older
- Fixed in
- 1.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Duplicate Page plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.7. This is due to the plugin not properly verifying that a user is authorized to perform an action in the 'saveSettings' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify plugin settings that control role capabilities, and subsequently exploit the misconfigured capabilities to duplicate and view password-protected posts containing sensitive information.
NVD CVE-2025-12481Wordfence advisoryCode change (fix)Plugin source
medium 4.8 CVE-2022-2093 · published 2022-07-11
Cross-site scripting (XSS) in WP Duplicate Page (older than 1.3)
- Affected
- older than 1.3
- Fixed in
- 1.3
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The WP Duplicate Page WordPress plugin before 1.3 does not sanitize and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Recent activity
- 2026-09-08 — latest release on wordpress.org (1.8.7).
- 2026-01-13 — Missing authorization check disclosed (CVE-2025-14001), fixed in 1.8.1.
- 2025-11-18 — Missing authorization check disclosed (CVE-2025-12481), fixed in 1.8.
- 2022-07-11 — Cross-site scripting (XSS) disclosed (CVE-2022-2093), fixed in 1.3.
Get an email when WP Duplicate Page has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Duplicate Page (wp-duplicate-page) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ninja Team (4 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-duplicate-page (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-duplicate-page"><img src="https://laskyr.com/plugins/wp-duplicate-page/badge.svg" alt="WP Duplicate Page vulnerability status"></a>