Skip to content
Laskyr

Plugins · wp-docs · data as of 2026-11-04

Is WP Docs safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.6)

As of 2026-11-04. 10 issues are on record for older versions; version 2.3.2 or newer fixes all of them that state a fix.

Latest version
2.3.6
Last updated
2026-11-02
Active installs
1,000+
Known issues on record
10
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A documents management tool for education portals. — by Fahad Mahmood

What to do

  1. Update to the latest version (2.3.6). Anything older than 2.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-docs --field=version shows what you run; wp plugin update wp-docs updates it.

Check your version

Known vulnerabilities

10 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-81782 · published 2026-09-10

Cross-site scripting (XSS) in WP Docs (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in WP Docs <= 2.3.1 versions.

NVD CVE-2026-81782Patchstack advisory

medium 6.4 CVE-2026-3878 · published 2026-04-16

Stored cross-site scripting (XSS) in WP Docs (2.2.9 and older)

Affected
2.2.9 and older
Fixed in
2.3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Docs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpdocs_options[icon_size]' parameter in all versions up to, and including, 2.2.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-3878Wordfence advisoryCode change (fix)

medium 5.4 CVE-2026-24990 · published 2026-02-03

Missing authorization check in WP Docs (2.2.8 and older)

Affected
2.2.8 and older
Fixed in
2.2.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood WP Docs wp-docs allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Docs: from n/a through <= 2.2.8.

NVD CVE-2026-24990Patchstack advisory

medium 4.3 CVE-2025-31417 · published 2025-03-31

Missing authorization check in WP Docs (2.2.7 and older)

Affected
2.2.7 and older
Fixed in
2.2.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood WP Docs wp-docs allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Docs: from n/a through < 2.2.7.

NVD CVE-2025-31417Patchstack advisory

medium 4.8 CVE-2024-56288 · published 2025-01-07

Stored cross-site scripting (XSS) in WP Docs (2.2.1 and older)

Affected
2.2.1 and older
Fixed in
2.2.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fahad Mahmood WP Docs wp-docs allows Stored XSS.This issue affects WP Docs: from n/a through <= 2.2.1.

NVD CVE-2024-56288Patchstack advisory

medium 6.5 CVE-2024-12635 · published 2024-12-21

SQL injection in WP Docs (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Docs plugin for WordPress is vulnerable to time-based SQL Injection via the 'dir_id' parameter in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The vulnerability was partially patched in version 2.2.0.

NVD CVE-2024-12635Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2023-30873 · published 2024-12-09

Missing authorization check in WP Docs (1.9.8 and older)

Affected
1.9.8 and older
Fixed in
1.9.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood WP Docs allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Docs: from n/a through 1.9.8.

NVD CVE-2023-30873Patchstack advisory

medium 5.4 CVE-2024-35695 · published 2024-06-08

Stored cross-site scripting (XSS) in WP Docs (2.1.3 and older)

Affected
2.1.3 and older
Fixed in
2.1.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Fahad Mahmood WP Docs allows Stored XSS.This issue affects WP Docs: from n/a through 2.1.3.

NVD CVE-2024-35695Patchstack advisory

medium 6.1 CVE-2024-35696 · published 2024-06-08

Reflected cross-site scripting (XSS) in WP Docs (2.1.3 and older)

Affected
2.1.3 and older
Fixed in
2.1.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Fahad Mahmood WP Docs allows Reflected XSS.This issue affects WP Docs: from n/a through 2.1.3.

NVD CVE-2024-35696Patchstack advisory

medium 6.1 CVE-2023-32106 · published 2023-08-18

Reflected cross-site scripting (XSS) in WP Docs (1.9.9 and older)

Affected
1.9.9 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Fahad Mahmood WP Docs plugin <= 1.9.9 versions.

NVD CVE-2023-32106Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Docs vulnerability status badge
<a href="https://laskyr.com/plugins/wp-docs"><img src="https://laskyr.com/plugins/wp-docs/badge.svg" alt="WP Docs vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit