Skip to content
Laskyr

Plugins · wp-debugging · data as of 2026-11-04

Is WP Debugging safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.12.6)

As of 2026-11-04. 2 issues are on record for older versions; version 2.12.3 or newer fixes all of them that state a fix.

Latest version
2.12.6
Last updated
2026-08-13
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

A support/troubleshooting plugin for WordPress. — by Andy Fragen

What to do

  1. Update to the latest version (2.12.6). Anything older than 2.12.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-debugging --field=version shows what you run; wp plugin update wp-debugging updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57350 · published 2026-07-02

Cross-site scripting (XSS) in WP Debugging (2.12.2 and older)

Affected
2.12.2 and older
Fixed in
2.12.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in WP Debugging <= 2.12.2 versions.

NVD CVE-2026-57350Patchstack advisory

medium 6.5 CVE-2021-24779 · published 2021-10-25

Cross-site request forgery (CSRF) in WP Debugging (older than 2.11.0)

Affected
older than 2.11.0
Fixed in
2.11.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The WP Debugging WordPress plugin before 2.11.0 has its update_settings() function hooked to admin_init and is missing any authorisation and CSRF checks, as a result, the settings can be updated by unauthenticated users.

NVD CVE-2021-24779WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Debugging vulnerability status badge
<a href="https://laskyr.com/plugins/wp-debugging"><img src="https://laskyr.com/plugins/wp-debugging/badge.svg" alt="WP Debugging vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit