Skip to content
Laskyr

Plugins · wp-db-backup · data as of 2026-11-04

Is Database Backup for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.3)

As of 2026-11-04. 6 issues are on record for older versions; version 2.5.3 or newer fixes all of them that state a fix.

Latest version
2.5.3
Last updated
2026-04-20
Active installs
60,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.3+

Database Backup for WordPress is your one-stop database backup solution for WordPress. — by WP Engine

What to do

  1. Update to the latest version (2.5.3). Anything older than 2.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-db-backup --field=version shows what you run; wp plugin update wp-db-backup updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-4029 · published 2026-05-14

Information disclosure in Database Backup for WordPress (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Database Backup for WordPress plugin for WordPress is vulnerable to unauthorized database export in all versions up to, and including, 2.5.2. This is due to the plugin not properly enforcing the return value of its authorization check. This makes it possible for unauthenticated attackers to export database tables, leading to Sensitive Information Exposure. Note: This vulnerability is only exploitable in WordPress Multisite environments where the deprecated is_site_admin() function exists.

NVD CVE-2026-4029Wordfence advisoryCode change (fix)Plugin source

high 8.1 CVE-2026-4030 · published 2026-05-14

Path traversal / file read in Database Backup for WordPress (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Database Backup for WordPress plugin for WordPress is vulnerable to unauthorized arbitrary file read and deletion in all versions up to, and including, 2.5.2. This is due to the plugin not properly enforcing the return value of its authorization check combined with a user-controlled backup directory parameter. This makes it possible for unauthenticated attackers to read and delete arbitrary files on the server, leading to Sensitive Information Exposure and potential site takeover. Note: This vulnerability is only exploitable in WordPress Multisite environments where the deprecated is_site_admin() function exists.

NVD CVE-2026-4030Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-4031 · published 2026-05-14

Information disclosure in Database Backup for WordPress (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Database Backup for WordPress plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.5.2. This is due to the plugin not restricting access to the wp_db_temp_dir parameter, which controls where database backups are written. This makes it possible for unauthenticated attackers to send a request to wp-cron.php with a poisoned wp_db_temp_dir value pointing to a publicly accessible directory (e.g., wp-content/uploads/), and if a scheduled backup is due, intercept the backup file before it is cleaned up. The backup file has a predictable name based on the database name, table prefix, date, and Swatch Internet Time, making interception reliable. Successful exploitation leads to Sensitive Information Exposure including database credentials, user password hashes, and personally identifiable information. This vulnerability requires that the site administrator has configured scheduled backups.

NVD CVE-2026-4031Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2022-1577 · published 2022-06-08

Cross-site request forgery (CSRF) in Database Backup for WordPress (older than 2.5.2)

Affected
older than 2.5.2
Fixed in
2.5.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Database Backup for WordPress plugin before 2.5.2 does not have CSRF check in place when updating the schedule backup settings, which could allow an attacker to make a logged in admin change them via a CSRF attack. This could lead to cases where attackers can send backup notification emails to themselves, which contain more details. Or disable the automatic backup schedule

NVD CVE-2022-1577WPScan advisory

high 7.2 CVE-2022-0255 · published 2022-02-21

SQL injection in Database Backup for WordPress (older than 2.5.1)

Affected
older than 2.5.1
Fixed in
2.5.1
Access needed (per CVSS)
Needs an admin-level account
Range from
advisory text · score by NVD
Details from the advisory

The Database Backup for WordPress plugin before 2.5.1 does not properly sanitise and escape the fragment parameter before using it in a SQL statement in the admin dashboard, leading to a SQL injection issue

NVD CVE-2022-0255WPScan advisory

medium 5.4 CVE-2021-24322 · published 2021-06-01

Stored cross-site scripting (XSS) in Database Backup for WordPress (older than 2.4)

Affected
older than 2.4
Fixed in
2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Database Backup for WordPress plugin before 2.4 did not escape the backup_recipient POST parameter in before output it back in the attribute of an HTML tag, leading to a Stored Cross-Site Scripting issue.

NVD CVE-2021-24322WPScan advisorym0ze.ru

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Database Backup for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/wp-db-backup"><img src="https://laskyr.com/plugins/wp-db-backup/badge.svg" alt="Database Backup for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit