Plugins · wp-custom-admin-interface · data as of 2026-11-04
Is WP Custom Admin Interface safe? Known vulnerabilities and latest version
- Latest version
- 7.43
- Last updated
- 2026-02-10
- Active installs
- 30,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
With WP Custom Admin Interface you can easily customise the WordPress admin and login interfaces. — by Northern Beaches Websites
What to do
- Update to the latest version (7.43). Anything older than 7.43 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-custom-admin-interface --field=version shows what you run; wp plugin update wp-custom-admin-interface updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-32521 · published 2026-03-25
Cross-site scripting (XSS) in WP Custom Admin Interface (7.42 and older)
- Affected
- 7.42 and older
- Fixed in
- 7.43
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Northern Beaches Websites WP Custom Admin Interface wp-custom-admin-interface allows DOM-Based XSS.This issue affects WP Custom Admin Interface: from n/a through <= 7.42.
medium 4.3 CVE-2026-25011 · published 2026-02-03
Missing authorization check in WP Custom Admin Interface (7.41 and older)
- Affected
- 7.41 and older
- Fixed in
- 7.42
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Northern Beaches Websites WP Custom Admin Interface wp-custom-admin-interface allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Custom Admin Interface: from n/a through <= 7.41.
medium 4.3 CVE-2025-63038 · published 2025-12-31
Missing authorization check in WP Custom Admin Interface (7.40 and older)
- Affected
- 7.40 and older
- Fixed in
- 7.41
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Northern Beaches Websites WP Custom Admin Interface wp-custom-admin-interface allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Custom Admin Interface: from n/a through <= 7.40.
medium 4.3 CVE-2023-44988 · published 2025-01-02
Missing authorization check in WP Custom Admin Interface (7.32 and older)
- Affected
- 7.32 and older
- Fixed in
- 7.33
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Martin Gibson WP Custom Admin Interface allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Custom Admin Interface: from n/a through 7.32.
medium 4.3 CVE-2023-47763 · published 2024-12-09
Missing authorization check in WP Custom Admin Interface (7.31 and older)
- Affected
- 7.31 and older
- Fixed in
- 7.32
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Northern Beaches Websites WP Custom Admin Interface wp-custom-admin-interface allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Custom Admin Interface: from n/a through <= 7.31.
high 7.2 CVE-2022-4043 · published 2023-01-09
PHP object injection in WP Custom Admin Interface (older than 7.29)
- Affected
- older than 7.29
- Fixed in
- 7.29
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Custom Admin Interface WordPress plugin before 7.29 unserialize user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
Recent activity
- 2026-02-10 — latest release on wordpress.org (7.43).
- 2026-03-25 — Cross-site scripting (XSS) disclosed (CVE-2026-32521), fixed in 7.43.
- 2026-02-03 — Missing authorization check disclosed (CVE-2026-25011), fixed in 7.42.
- 2025-12-31 — Missing authorization check disclosed (CVE-2025-63038), fixed in 7.41.
Get an email when WP Custom Admin Interface has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Custom Admin Interface (wp-custom-admin-interface) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (4) · Cross-site scripting (XSS) (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-custom-admin-interface (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-custom-admin-interface"><img src="https://laskyr.com/plugins/wp-custom-admin-interface/badge.svg" alt="WP Custom Admin Interface vulnerability status"></a>