Plugins · wp-crontrol · data as of 2026-11-01
Is WP Crontrol safe? Known vulnerabilities and latest version
- Latest version
- 2.0.0
- Last updated
- 2026-10-15
- Active installs
- 300,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Take control of the cron events on your WordPress website or WooCommerce store with WP Crontrol. — by Syed Balkhi
What to do
- Update to the latest version (2.0.0). Anything older than 1.19.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-crontrol --field=version shows what you run; wp plugin update wp-crontrol updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 CVE-2025-8678 · published 2025-08-22
Server-side request forgery (SSRF) in WP Crontrol (1.17.0 to 1.19.1)
- Affected
- 1.17.0 to 1.19.1
- Fixed in
- 1.19.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Crontrol plugin for WordPress is vulnerable to blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the 'wp_remote_request' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
NVD CVE-2025-8678Wordfence advisoryCode change (fix)Plugin source
high 8.1 CVE-2024-28850 · published 2024-03-25
Remote code execution in WP Crontrol (older than 1.16.2)
- Affected
- older than 1.16.2
- Fixed in
- 1.16.2
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by security-advisories@github.com
Details from the advisory
WP Crontrol controls the cron events on WordPress websites. WP Crontrol includes a feature that allows administrative users to create events in the WP-Cron system that store and execute PHP code subject to the restrictive security permissions documented here. While there is no known vulnerability in this feature on its own, there exists potential for this feature to be vulnerable to RCE if it were specifically targeted via vulnerability chaining that exploited a separate SQLi (or similar) vulnerability. This is exploitable on a site if one of the below preconditions are met, the site is vulnerable to a writeable SQLi vulnerability in any plugin, theme, or WordPress core, the site's database is compromised at the hosting level, the site is vulnerable to a method of updating arbitrary options in the wp_options table, or the site is vulnerable to a method of triggering an arbitrary action, filter, or function with control of the parameters. As a hardening measure, WP Crontrol version 1.16.2 ships with a new feature that prevents tampering of the code stored in a PHP cron event.
Recent activity
- 2026-10-15 — latest release on wordpress.org (2.0.0).
- 2025-08-22 — Server-side request forgery (SSRF) disclosed (CVE-2025-8678), fixed in 1.19.2.
- 2024-03-25 — Remote code execution disclosed (CVE-2024-28850), fixed in 1.16.2.
Get an email when WP Crontrol has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Crontrol (wp-crontrol) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-crontrol (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-crontrol"><img src="https://laskyr.com/plugins/wp-crontrol/badge.svg" alt="WP Crontrol vulnerability status"></a>