Skip to content
Laskyr

Plugins · wp-crm-system · data as of 2026-11-04

Is WP-CRM System safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.7)

As of 2026-11-04. 8 issues are on record for older versions; version 3.4.7 or newer fixes all of them that state a fix.

Latest version
3.4.7
Last updated
2026-09-28
Active installs
700+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WP-CRM System – Manage Clients and Projects is a WordPress CRM that is designed to work exclusively with YOUR WordPress site. — by Mario Peshev

What to do

  1. Update to the latest version (3.4.7). Anything older than 3.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-crm-system --field=version shows what you run; wp plugin update wp-crm-system updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-9004 · published 2026-09-22

Information disclosure in WP-CRM System (3.4.6 and older)

Affected
3.4.6 and older
Fixed in
3.4.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP-CRM System – Manage Clients and Projects plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.4.6 via the 'contact_id' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract full names, email addresses, phone numbers, mobile numbers, fax numbers, and physical address information of arbitrary CRM contact records by enumerating the contact_id parameter.

NVD CVE-2026-9004Wordfence advisoryPlugin source

medium 5.4 CVE-2025-62106 · published 2026-01-22

Missing authorization check in WP-CRM System (3.4.5 and older)

Affected
3.4.5 and older
Fixed in
3.4.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mario Peshev WP-CRM System wp-crm-system allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP-CRM System: from n/a through <= 3.4.5.

NVD CVE-2025-62106Patchstack advisory

medium 5.4 CVE-2025-14854 · published 2026-01-14

Missing authorization check in WP-CRM System (3.4.5 and older)

Affected
3.4.5 and older
Fixed in
3.4.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP-CRM System plugin for WordPress is vulnerable to unauthorized access due to missing capability checks on the wpcrm_get_email_recipients and wpcrm_system_ajax_task_change_status AJAX functions in all versions up to, and including, 3.4.5. This makes it possible for authenticated attackers, with subscriber level access and above, to enumerate CRM contact email addresses (PII disclosure) and modify CRM task statuses. CVE-2025-62106 is likely a duplicate of this issue.

NVD CVE-2025-14854Wordfence advisoryPlugin source

medium 5.3 CVE-2025-62740 · published 2025-12-09

Missing authorization check in WP-CRM System (3.4.6 and older)

Affected
3.4.6 and older
Fixed in
3.4.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mario Peshev WP-CRM System wp-crm-system allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP-CRM System: from n/a through <= 3.4.6.

NVD CVE-2025-62740Patchstack advisory

medium 5.3 CVE-2025-49270 · published 2025-06-06

Missing authorization check in WP-CRM System (3.4.2 and older)

Affected
3.4.2 and older
Fixed in
3.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mario Peshev WP-CRM System wp-crm-system allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WP-CRM System: from n/a through <= 3.4.2.

NVD CVE-2025-49270Patchstack advisory

high 7.2 CVE-2025-47629 · published 2025-05-07

PHP object injection in WP-CRM System (3.4.5 and older)

Affected
3.4.5 and older
Fixed in
3.4.6
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Deserialization of Untrusted Data vulnerability in Mario Peshev WP-CRM System wp-crm-system allows Object Injection.This issue affects WP-CRM System: from n/a through <= 3.4.5.

NVD CVE-2025-47629Patchstack advisory

medium 6.5 CVE-2024-55991 · published 2024-12-31

Missing authorization check in WP-CRM System (3.2.9.1 and older)

Affected
3.2.9.1 and older
Fixed in
3.4.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mario Peshev WP-CRM System wp-crm-system allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP-CRM System: from n/a through <= 3.2.9.1.

NVD CVE-2024-55991Patchstack advisory

medium 5.9 CVE-2024-30434 · published 2024-03-29

Stored cross-site scripting (XSS) in WP-CRM System (3.2.9 and older)

Affected
3.2.9 and older
Fixed in
3.2.9.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP-CRM System allows Stored XSS.This issue affects WP-CRM System: from n/a through 3.2.9.

NVD CVE-2024-30434Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-CRM System vulnerability status badge
<a href="https://laskyr.com/plugins/wp-crm-system"><img src="https://laskyr.com/plugins/wp-crm-system/badge.svg" alt="WP-CRM System vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit