Skip to content
Laskyr

Plugins · wp-courses · data as of 2026-11-04

Is WP Courses LMS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.30)

As of 2026-11-04. 4 issues are on record for older versions; version 3.2.30 or newer fixes all of them that state a fix.

Latest version
3.2.30
Last updated
2026-08-22
Active installs
500+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

WP Courses LMS - Create Courses, Lessons, Quizzes, Profiles and more. Online Courses Builder, eLearning Courses, Courses Solution, Education Courses. — by hookandhook

What to do

  1. Update to the latest version (3.2.30). Anything older than 3.2.30 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-courses --field=version shows what you run; wp plugin update wp-courses updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-10630 · published 2026-08-25

Missing authorization check in WP Courses LMS (3.2.29 and older)

Affected
3.2.29 and older
Fixed in
3.2.30 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Courses LMS – Online Courses Builder, eLearning Courses, Courses Solution, Education Courses plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.2.29 via the 'resultID' parameter due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with custom-level access and above, to read any other user's quiz answers and scores by enumerating the incrementing resultID value via the wpcq_get_quiz_result AJAX action. The only access control on this endpoint is a nonce check (wpc_nonce) that is exposed to every logged-in user on the frontend, providing no meaningful authorization barrier.

NVD CVE-2026-10630Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-31914 · published 2026-03-25

Cross-site scripting (XSS) in WP Courses LMS (3.2.26 and older)

Affected
3.2.26 and older
Fixed in
3.2.27
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hookandhook WP Courses LMS wp-courses allows DOM-Based XSS.This issue affects WP Courses LMS: from n/a through <= 3.2.26.

NVD CVE-2026-31914Patchstack advisory

high 7.5 CVE-2024-12172 · published 2024-12-12

Missing authorization check in WP Courses LMS (3.2.21 and older)

Affected
3.2.21 and older
Fixed in
3.2.22 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Courses LMS – Online Courses Builder, eLearning Courses, Courses Solution, Education Courses plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the wpc_update_user_meta_option() function in all versions up to, and including, 3.2.21. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary user's metadata which can be levereged to block an administrator from accessing their site when wp_capabilities is set to 0.

NVD CVE-2024-12172Wordfence advisoryCode change (fix)

medium 4.8 CVE-2021-24621 · published 2021-09-13

Stored cross-site scripting (XSS) in WP Courses LMS (older than 2.0.44)

Affected
older than 2.0.44
Fixed in
2.0.44
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The WP Courses LMS WordPress plugin before 2.0.44 does not sanitise its Video Embed Code, allowing malicious code to be injected in it by high privilege users, even when the unfiltered_html capability is disallowed, which could lead to Stored Cross-Site Scripting issues

NVD CVE-2021-24621WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Courses LMS vulnerability status badge
<a href="https://laskyr.com/plugins/wp-courses"><img src="https://laskyr.com/plugins/wp-courses/badge.svg" alt="WP Courses LMS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit