Plugins · wp-cors · data as of 2026-11-04
Is WP-CORS safe? Known vulnerabilities and latest version
- Latest version
- 0.2.2
- Last updated
- 2023-07-28
- Active installs
- 1,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.2.15
Allows AJAX requests from other sites to integrate content from your site using the CORS standard. — by tstephenson
What to do
- There is no fixed version yet. If you can live without WP-CORS for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wp-cors --field=version shows what you run; wp plugin update wp-cors updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 affects latest 0.2.2 CVE-2026-25410 · published 2026-02-19
Missing authorization check in WP-CORS (0.2.2 and older)
- Affected
- 0.2.2 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in tstephenson WP-CORS wp-cors allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP-CORS: from n/a through <= 0.2.2.
medium 4.8 CVE-2022-47606 · published 2023-05-10
Stored cross-site scripting (XSS) in WP-CORS (0.2.1 and older)
- Affected
- 0.2.1 and older
- Fixed in
- 0.2.2 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Tim Stephenson WP-CORS plugin <= 0.2.1 versions.
Recent activity
- 2023-07-28 — latest release on wordpress.org (0.2.2).
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-25410), no fix listed yet.
- 2023-05-10 — Stored cross-site scripting (XSS) disclosed (CVE-2022-47606), fixed in 0.2.2.
Get an email when WP-CORS has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP-CORS (wp-cors) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-cors (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-cors"><img src="https://laskyr.com/plugins/wp-cors/badge.svg" alt="WP-CORS vulnerability status"></a>