Plugins · wp-content-pilot · data as of 2026-11-04
Is Content Pilot safe? Known vulnerabilities and latest version
- Latest version
- 2.2.5
- Last updated
- 2026-10-18
- Active installs
- 700+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Automatically post contents, create news feeds, import and display unlimited RSS feeds from various sources in a few clicks! — by PluginEver
What to do
- Update to the latest version (2.2.5). Anything older than 2.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-content-pilot --field=version shows what you run; wp plugin update wp-content-pilot updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-111070 · published 2026-10-31
Stored cross-site scripting (XSS) in Content Pilot (2.2.4 and older)
- Affected
- 2.2.4 and older
- Fixed in
- 2.2.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Content Pilot – Autoblogging & Affiliate Marketing Suite plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.2.4. This is due to the plugin extracting the HTML meta description from each remotely-fetched article (WPCP_Readability::parse_meta()), piping that value through the article template substitution and html_entity_decode() in WPCP_Module::insert_post(), and then calling wp_insert_post() after switching the current user to the configured campaign author (an Administrator with the unfiltered_html capability by default) — so no wp_kses_post sanitization is applied to the attacker-controlled HTML before it is persisted as post_content and rendered on the front end. This makes it possible for unauthenticated attackers who control the content of any RSS source an administrator has configured a Content Pilot RSS campaign to consume to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2025-64263 · published 2025-11-13
Missing authorization check in Content Pilot (2.1.7 and older)
- Affected
- 2.1.7 and older
- Fixed in
- 2.1.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in PluginEver WP Content Pilot wp-content-pilot allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Content Pilot: from n/a through <= 2.1.7.
medium 4.3 CVE-2023-45053 · published 2024-06-04
Cross-site scripting (XSS) in Content Pilot (1.3.3 and older)
- Affected
- 1.3.3 and older
- Fixed in
- 1.3.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in pluginever WP Content Pilot – Autoblogging & Affiliate Marketing Plugin allows Code Injection.This issue affects WP Content Pilot – Autoblogging & Affiliate Marketing Plugin: from n/a through 1.3.3.
Recent activity
- 2026-10-18 — latest release on wordpress.org (2.2.5).
- 2026-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2026-111070), fixed in 2.2.5.
- 2025-11-13 — Missing authorization check disclosed (CVE-2025-64263), fixed in 2.1.8.
- 2024-06-04 — Cross-site scripting (XSS) disclosed (CVE-2023-45053), fixed in 1.3.4.
Get an email when Content Pilot has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Content Pilot (wp-content-pilot) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-content-pilot (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-content-pilot"><img src="https://laskyr.com/plugins/wp-content-pilot/badge.svg" alt="Content Pilot vulnerability status"></a>