Skip to content
Laskyr

Plugins · wp-compress-mainwp · data as of 2026-11-04

Is WP Compress for MainWP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.22.00)

As of 2026-11-04. 3 issues are on record for older versions; version 6.60.17 or newer fixes all of them that state a fix.

Latest version
7.22.00
Last updated
2026-08-31
Active installs
400+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Install, activate and connect WP Compress across all of your MainWP Child Sites. — by WP Compress

What to do

  1. Update to the latest version (7.22.00). Anything older than 6.60.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-compress-mainwp --field=version shows what you run; wp plugin update wp-compress-mainwp updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-64639 · published 2025-12-16

Missing authorization check in WP Compress for MainWP (6.50.17 and older)

Affected
6.50.17 and older
Fixed in
6.60.17 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Compress WP Compress for MainWP wp-compress-mainwp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Compress for MainWP: from n/a through <= 6.50.17.

NVD CVE-2025-64639Patchstack advisory

medium 5.4 CVE-2025-30932 · published 2025-06-06

Missing authorization check in WP Compress for MainWP (6.30.32 and older)

Affected
6.30.32 and older
Fixed in
6.50.05
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Compress WP Compress for MainWP wp-compress-mainwp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Compress for MainWP: from n/a through <= 6.30.32.

NVD CVE-2025-30932Patchstack advisory

medium 4.9 CVE-2025-31076 · published 2025-03-28

Server-side request forgery (SSRF) in WP Compress for MainWP (6.30.03 and older)

Affected
6.30.03 and older
Fixed in
6.30.06
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in WP Compress WP Compress for MainWP wp-compress-mainwp allows Server Side Request Forgery.This issue affects WP Compress for MainWP: from n/a through <= 6.30.03.

NVD CVE-2025-31076Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Compress for MainWP vulnerability status badge
<a href="https://laskyr.com/plugins/wp-compress-mainwp"><img src="https://laskyr.com/plugins/wp-compress-mainwp/badge.svg" alt="WP Compress for MainWP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit