Skip to content
Laskyr

Plugins · wp-cloudflare-page-cache · data as of 2026-11-04

Is Super Page Cache safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.3.8)

As of 2026-11-04. 2 issues are on record for older versions; version 5.2.3 or newer fixes all of them that state a fix.

Latest version
5.3.8
Last updated
2026-10-20
Active installs
70,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Boost PageSpeed, SEO, and Core Web Vitals with full page caching, JS/CSS optimization, media optimization, and Cloudflare CDN. — by Optimole

What to do

  1. Update to the latest version (5.3.8). Anything older than 5.2.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-cloudflare-page-cache --field=version shows what you run; wp plugin update wp-cloudflare-page-cache updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-1843 · published 2026-02-14

Stored cross-site scripting (XSS) in Super Page Cache (5.2.2 and older)

Affected
5.2.2 and older
Fixed in
5.2.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Super Page Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Activity Log in all versions up to, and including, 5.2.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1843Wordfence advisoryCode change (fix)

medium 6.1 CVE-2024-27968 · published 2024-03-21

Cross-site request forgery (CSRF) in Super Page Cache (4.7.5 and older)

Affected
4.7.5 and older
Fixed in
4.7.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Optimole Super Page Cache for Cloudflare allows Stored XSS.This issue affects Super Page Cache for Cloudflare: from n/a through 4.7.5.

NVD CVE-2024-27968Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Super Page Cache vulnerability status badge
<a href="https://laskyr.com/plugins/wp-cloudflare-page-cache"><img src="https://laskyr.com/plugins/wp-cloudflare-page-cache/badge.svg" alt="Super Page Cache vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit