Skip to content
Laskyr

Plugins · wp-carousel-free · data as of 2026-11-04

Is AI-Powered Carousel, Slider, Video & Photo Gal… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.0.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.7.11 or newer fixes all of them that state a fix.

Latest version
5.0.1
Last updated
2026-10-28
Active installs
60,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Image carousel, slider, and slideshow blocks with AI and ready patterns. Photo gallery, video slider, post and WooCommerce product carousels. — by ShapedPlugin LLC

What to do

  1. Update to the latest version (5.0.1). Anything older than 2.7.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-carousel-free --field=version shows what you run; wp plugin update wp-carousel-free updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4665 · published 2026-05-05

Stored cross-site scripting (XSS) in AI-Powered Carousel, Slider, Video & Photo Gal… (2.7.10 and older)

Affected
2.7.10 and older
Fixed in
2.7.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Carousel Free plugin for WordPress is vulnerable to Stored Cross-Site Scripting via crafted fancybox `data-caption` attributes in all versions up to, and including, 2.7.10. This is due to the `fancybox-config.js` script reading the carousel container's `id` attribute directly from the DOM to construct a jQuery selector without sanitization. When a Contributor crafts an HTML block with a malformed carousel container ID (containing characters invalid for jQuery selectors), the custom fancybox configuration throws a JavaScript error and fails to initialize. This causes the bundled fancybox library (v3.5.7) to fall back to its default caption handling, which renders the `data-caption` attribute content as raw HTML. Since WordPress allows `data-*` attributes through `wp_kses_post()`, this makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user clicks an image in the crafted carousel lightbox.

NVD CVE-2026-4665Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2024-3020 · published 2024-04-10

PHP object injection in AI-Powered Carousel, Slider, Video & Photo Gal… (2.6.3 and older)

Affected
2.6.3 and older
Fixed in
2.6.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The plugin is vulnerable to PHP Object Injection in versions up to and including, 2.6.3 via deserialization of untrusted input in the import function via the 'shortcode' parameter. This allows authenticated attackers, with administrator-level access to inject a PHP Object. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2024-3020Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-2949 · published 2024-04-06

Stored cross-site scripting (XSS) in AI-Powered Carousel, Slider, Video & Photo Gal… (2.6.3 and older)

Affected
2.6.3 and older
Fixed in
2.6.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Carousel, Slider, Gallery by WP Carousel – Image Carousel & Photo Gallery, Post Carousel & Post Grid, Product Carousel & Product Grid for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the carousel widget in all versions up to, and including, 2.6.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2949Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AI-Powered Carousel, Slider, Video & Photo Gal… vulnerability status badge
<a href="https://laskyr.com/plugins/wp-carousel-free"><img src="https://laskyr.com/plugins/wp-carousel-free/badge.svg" alt="AI-Powered Carousel, Slider, Video & Photo Gal… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit