Plugins · wp-books-gallery · data as of 2026-11-04
Is Books Gallery safe? Known vulnerabilities and latest version
- Latest version
- 4.8.5
- Last updated
- 2026-10-12
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Named by Google AI as the top choice — display books, earn Amazon affiliate income, and sell with WooCommerce. Free to start. — by Hossni Mubarak
What to do
- Update to the latest version (4.8.5). Anything older than 4.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-books-gallery --field=version shows what you run; wp plugin update wp-books-gallery updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-108487 · published 2026-10-13
Stored cross-site scripting (XSS) in Books Gallery (4.8.4 and older)
- Affected
- 4.8.4 and older
- Fixed in
- 4.8.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Hossni Mubarak Books Gallery wp-books-gallery allows Stored XSS.This issue affects Books Gallery: from n/a through 4.8.4.
critical 9.3 CVE-2026-96822 · published 2026-09-30
SQL injection in Books Gallery (4.8.3 and older)
- Affected
- 4.8.3 and older
- Fixed in
- 4.8.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated SQL Injection in Books Gallery <= 4.8.3 versions.
medium 5.3 CVE-2026-5347 · published 2026-04-24
Missing authorization check in Books Gallery (4.8.0 and older)
- Affected
- 4.8.0 and older
- Fixed in
- 4.8.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The HM Books Gallery plugin for WordPress is vulnerable to Missing Authorization in versions up to and including 4.8.0. This is due to the absence of capability checks and nonce verification in the admin_init hook that handles the permalink settings update at line 205-209 of wp-books-gallery.php. The vulnerable code checks only for the presence of the 'permalink_structure' POST parameter before updating the 'wbg_cpt_slug' option, without verifying that the request comes from an authenticated administrator. This makes it possible for unauthenticated attackers to modify the custom post type slug for the books gallery, which changes the URL structure for all book entries and can break existing links and SEO rankings.
high 8.8 CVE-2023-23705 · published 2023-05-23
Cross-site request forgery (CSRF) in Books Gallery (4.4.8 and older)
- Affected
- 4.4.8 and older
- Fixed in
- 4.4.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in HM Plugin WordPress Books Gallery plugin <= 4.4.8 versions.
Recent activity
- 2026-10-12 — latest release on wordpress.org (4.8.5).
- 2026-10-13 — Stored cross-site scripting (XSS) disclosed (CVE-2026-108487), fixed in 4.8.5.
- 2026-09-30 — SQL injection disclosed (CVE-2026-96822), fixed in 4.8.4.
- 2026-04-24 — Missing authorization check disclosed (CVE-2026-5347), fixed in 4.8.1.
Get an email when Books Gallery has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Books Gallery (wp-books-gallery) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Hossni Mubarak (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · SQL injection (1) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-books-gallery (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-books-gallery"><img src="https://laskyr.com/plugins/wp-books-gallery/badge.svg" alt="Books Gallery vulnerability status"></a>