Skip to content
Laskyr

Plugins · wp-auto-affiliate-links · data as of 2026-11-04

Is Auto Affiliate Links safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.9.9.1)

As of 2026-11-04. 9 issues are on record for older versions; version 6.8.9 or newer fixes all of them that state a fix.

Latest version
6.9.9.1
Last updated
2026-10-02
Active installs
2,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4

Automatically display affiliate links in your website content so you can make more money. It is also working well for internal linking. — by Lucian Apostol

What to do

  1. Update to the latest version (6.9.9.1). Anything older than 6.8.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-auto-affiliate-links --field=version shows what you run; wp plugin update wp-auto-affiliate-links updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-24592 · published 2026-05-25

Missing authorization check in Auto Affiliate Links (6.8.8.3 and older)

Affected
6.8.8.3 and older
Fixed in
6.8.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Lucian Apostol Auto Affiliate Links allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Auto Affiliate Links: from n/a through 6.8.8.3.

NVD CVE-2026-24592Patchstack advisory

high 7.2 CVE-2026-7330 · published 2026-05-08

Stored cross-site scripting (XSS) in Auto Affiliate Links (6.8.8 and older)

Affected
6.8.8 and older
Fixed in
6.8.8.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Auto Affiliate Links plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 6.8.8 This is due to insufficient input sanitization on the 'url' POST parameter in the aal_url_stats_save_action() function and a complete absence of output escaping in aal_display_clicks(), where the stored value is echoed directly into an anchor element's href attribute and inner text without esc_url(), esc_attr(), or esc_html(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts into the admin statistics page that execute in an administrator's browser when the page is visited, leveraging a publicly exposed nonce and an unauthenticated AJAX endpoint registered via the wp_ajax_nopriv_ hook.

NVD CVE-2026-7330Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-9838 · published 2025-05-15

SQL injection in Auto Affiliate Links (older than 6.4.7)

Affected
older than 6.4.7
Fixed in
6.4.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Auto Affiliate Links WordPress plugin before 6.4.7 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks

NVD CVE-2024-9838WPScan advisory

medium 6.5 CVE-2022-45840 · published 2024-12-13

Missing authorization check in Auto Affiliate Links (6.2.1.5 and older)

Affected
6.2.1.5 and older
Fixed in
6.2.1.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Lucian Apostol Auto Affiliate Links allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Auto Affiliate Links: from n/a through 6.2.1.5.

NVD CVE-2022-45840Patchstack advisory

high 7.6 CVE-2024-34386 · published 2024-05-06

SQL injection in Auto Affiliate Links (6.4.3.1 and older)

Affected
6.4.3.1 and older
Fixed in
6.4.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Lucian Apostol Auto Affiliate Links.This issue affects Auto Affiliate Links: from n/a through 6.4.3.1.

NVD CVE-2024-34386Patchstack advisory

medium 4.3 CVE-2024-1843 · published 2024-03-13

Missing authorization check in Auto Affiliate Links (6.4.3 and older)

Affected
6.4.3 and older
Fixed in
6.4.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Auto Affiliate Links plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the aalAddLink function in all versions up to, and including, 6.4.3. This makes it possible for authenticated attackers, with subscriber access or higher, to add arbitrary links to posts.

NVD CVE-2024-1843Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2023-47652 · published 2023-11-13

Cross-site request forgery (CSRF) in Auto Affiliate Links (6.4.2.4 and older)

Affected
6.4.2.4 and older
Fixed in
6.4.2.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Lucian Apostol Auto Affiliate Links allows Stored XSS.This issue affects Auto Affiliate Links: from n/a through 6.4.2.4.

NVD CVE-2023-47652Patchstack advisory

high 8.8 CVE-2023-22689 · published 2023-05-20

Cross-site request forgery (CSRF) in Auto Affiliate Links (6.3 and older)

Affected
6.3 and older
Fixed in
6.3.0.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Lucian Apostol Auto Affiliate Links plugin <= 6.3 versions.

NVD CVE-2023-22689Patchstack advisory

high 8.8 CVE-2023-25973 · published 2023-03-13

Cross-site request forgery (CSRF) in Auto Affiliate Links (6.3.0.2 and older)

Affected
6.3.0.2 and older
Fixed in
6.3.0.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Lucian Apostol Auto Affiliate Links plugin <= 6.3.0.2 versions.

NVD CVE-2023-25973Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Auto Affiliate Links vulnerability status badge
<a href="https://laskyr.com/plugins/wp-auto-affiliate-links"><img src="https://laskyr.com/plugins/wp-auto-affiliate-links/badge.svg" alt="Auto Affiliate Links vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit