Skip to content
Laskyr

Plugins · wp-attachments · data as of 2026-11-04

Is WP Attachments safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.1)

As of 2026-11-04. 5 issues are on record for older versions; version 5.2.1 or newer fixes all of them that state a fix.

Latest version
6.1
Last updated
2026-10-05
Active installs
3,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.2 · PHP 7.4+

Attach files to any post or page and let WP Attachments list them for you, with icons, file sizes and a download counter. — by Marco Milesi

What to do

  1. Update to the latest version (6.1). Anything older than 5.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-attachments --field=version shows what you run; wp plugin update wp-attachments updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2025-62888 · published 2025-12-31

Missing authorization check in WP Attachments (5.2 and older)

Affected
5.2 and older
Fixed in
5.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Marco Milesi WP Attachments wp-attachments allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Attachments: from n/a through <= 5.2.

NVD CVE-2025-62888Patchstack advisory

medium 6.1 CVE-2025-5082 · published 2025-05-28

Reflected cross-site scripting (XSS) in WP Attachments (5.0.12 and older)

Affected
5.0.12 and older
Fixed in
5.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Attachments plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘attachment_id’ parameter in all versions up to, and including, 5.0.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2025-5082Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 8.8 CVE-2023-45651 · published 2023-10-16

Cross-site request forgery (CSRF) in WP Attachments (5.0.11 and older)

Affected
5.0.11 and older
Fixed in
5.0.12
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Marco Milesi WP Attachments allows Cross Site Request Forgery.This issue affects WP Attachments: from n/a through 5.0.11.

NVD CVE-2023-45651Patchstack advisory

medium 4.8 CVE-2022-4330 · published 2023-01-16

Stored cross-site scripting (XSS) in WP Attachments (older than 5.0.6)

Affected
older than 5.0.6
Fixed in
5.0.6
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Attachments WordPress plugin before 5.0.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2022-4330WPScan advisory

medium 4.8 CVE-2022-3469 · published 2022-11-14

Stored cross-site scripting (XSS) in WP Attachments (older than 5.0.5)

Affected
older than 5.0.5
Fixed in
5.0.5
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The WP Attachments WordPress plugin before 5.0.5 does not sanitize and escapes some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).

NVD CVE-2022-3469WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Attachments vulnerability status badge
<a href="https://laskyr.com/plugins/wp-attachments"><img src="https://laskyr.com/plugins/wp-attachments/badge.svg" alt="WP Attachments vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit