Plugins · wp-associate-post-r2 · data as of 2026-11-04
Is WP Associate Post R2 safe? Known vulnerabilities and latest version
- Latest version
- 5.0.2
- Last updated
- 2026-09-30
- Active installs
- 2,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.3+
Affiliate easy installation plugin. Contributing to the monetization of your blog. — by Delight Star Inc.
What to do
- Update to the latest version (5.0.2). Anything older than 5.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-associate-post-r2 --field=version shows what you run; wp plugin update wp-associate-post-r2 updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-105870 · published 2026-10-09
Reflected cross-site scripting (XSS) in WP Associate Post R2 (5.0.1 and older)
- Affected
- 5.0.1 and older
- Fixed in
- 5.0.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Delight Star Inc. WP Associate Post R2 wp-associate-post-r2 allows Reflected XSS.This issue affects WP Associate Post R2: from n/a through 5.0.1.
Recent activity
- 2026-09-30 — latest release on wordpress.org (5.0.2).
- 2026-10-09 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-105870), fixed in 5.0.2.
Get an email when WP Associate Post R2 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Associate Post R2 (wp-associate-post-r2) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-associate-post-r2 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-associate-post-r2"><img src="https://laskyr.com/plugins/wp-associate-post-r2/badge.svg" alt="WP Associate Post R2 vulnerability status"></a>