Skip to content
Laskyr

Plugins · wp-asset-clean-up · data as of 2026-11-04

Is Asset CleanUp safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.0.6)

As of 2026-11-04. 9 issues are on record for older versions; version 1.4.0.6 or newer fixes all of them that state a fix.

Latest version
1.4.0.6
Last updated
2026-09-16
Active installs
100,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Speed up your WordPress site by unloading unnecessary CSS and JavaScript, reducing page bloat, and managing your own Critical CSS per page type. — by Gabe Livan

What to do

  1. Update to the latest version (1.4.0.6). Anything older than 1.4.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-asset-clean-up --field=version shows what you run; wp plugin update wp-asset-clean-up updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.5 CVE-2026-12037 · published 2026-09-25

Server-side request forgery (SSRF) in Asset CleanUp (1.4.0.5 and older)

Affected
1.4.0.5 and older
Fixed in
1.4.0.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Asset CleanUp: Page Speed Booster plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.4.0.5 via the 'page_url' parameter. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This vulnerability is only reachable when the plugin's dom_get_type setting has been configured to 'wp_remote_post' by an administrator.

NVD CVE-2026-12037Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-13354 · published 2026-09-19

Stored cross-site scripting (XSS) in Asset CleanUp (1.4.0.5 and older)

Affected
1.4.0.5 and older
Fixed in
1.4.0.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Asset CleanUp: Page Speed Booster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content in all versions up to, and including, 1.4.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable on instances where combine_loaded_css has been enabled.

NVD CVE-2026-13354Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source

high 7.1 CVE-2026-66571 · published 2026-09-17

Cross-site request forgery (CSRF) in Asset CleanUp (1.4.0.5 and older)

Affected
1.4.0.5 and older
Fixed in
1.4.0.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Asset CleanUp: Page Speed Booster <= 1.4.0.5 versions.

NVD CVE-2026-66571Patchstack advisory

medium 5.3 CVE-2026-45212 · published 2026-05-12

Missing authorization check in Asset CleanUp (1.4.0.3 and older)

Affected
1.4.0.3 and older
Fixed in
1.4.0.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Gabe Livan Asset CleanUp: Page Speed Booster wp-asset-clean-up allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Asset CleanUp: Page Speed Booster: from n/a through <= 1.4.0.3.

NVD CVE-2026-45212Patchstack advisory

medium 4.4 CVE-2024-53738 · published 2024-11-30

Server-side request forgery (SSRF) in Asset CleanUp (1.3.9.8 and older)

Affected
1.3.9.8 and older
Fixed in
1.3.9.9
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Gabe Livan Asset CleanUp: Page Speed Booster wp-asset-clean-up allows Server Side Request Forgery.This issue affects Asset CleanUp: Page Speed Booster: from n/a through <= 1.3.9.8.

NVD CVE-2024-53738Patchstack advisory

high 8.8 CVE-2024-43314 · published 2024-11-01

Missing authorization check in Asset CleanUp (1.3.9.3 and older)

Affected
1.3.9.3 and older
Fixed in
1.3.9.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Gabe Livan Asset CleanUp: Page Speed Booster allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Asset CleanUp: Page Speed Booster: from n/a through 1.3.9.3.

NVD CVE-2024-43314Patchstack advisory

medium 4.8 CVE-2021-36899 · published 2022-10-11

Reflected cross-site scripting (XSS) in Asset CleanUp (1.3.8.4 and older)

Affected
1.3.8.4 and older
Fixed in
1.3.8.5 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (admin+) Reflected Cross-Site Scripting (XSS) vulnerability in Gabe Livan's Asset CleanUp: Page Speed Booster plugin <= 1.3.8.4 at WordPress.

NVD CVE-2021-36899Patchstack advisorywordpress.org

medium 6.1 CVE-2021-24983 · published 2022-02-01

Reflected cross-site scripting (XSS) in Asset CleanUp (older than 1.3.8.5)

Affected
older than 1.3.8.5
Fixed in
1.3.8.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Asset CleanUp: Page Speed Booster WordPress plugin before 1.3.8.5 does not sanitise and escape POSted parameters sent to the wpassetcleanup_fetch_active_plugins_icons AJAX action (available to admin users), leading to a Reflected Cross-Site Scripting issue

NVD CVE-2021-24983WPScan advisory

medium 6.1 CVE-2021-24937 · published 2022-02-01

Reflected cross-site scripting (XSS) in Asset CleanUp (older than 1.3.8.5)

Affected
older than 1.3.8.5
Fixed in
1.3.8.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Asset CleanUp: Page Speed Booster WordPress plugin before 1.3.8.5 does not escape the wpacu_selected_sub_tab_area parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting issue

NVD CVE-2021-24937WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Asset CleanUp vulnerability status badge
<a href="https://laskyr.com/plugins/wp-asset-clean-up"><img src="https://laskyr.com/plugins/wp-asset-clean-up/badge.svg" alt="Asset CleanUp vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit