Skip to content
Laskyr

Plugins · wp-affiliate-disclosure · data as of 2026-11-04

Is WP Affiliate Disclosure safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.8 or newer fixes all of them that state a fix.

Latest version
1.4.1
Last updated
2026-10-12
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Automatically add a customizable, FTC-compliant disclosure statement across your WordPress website based on the rule(s) you define. — by mojofywp

What to do

  1. Update to the latest version (1.4.1). Anything older than 1.2.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-affiliate-disclosure --field=version shows what you run; wp plugin update wp-affiliate-disclosure updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2023-47232 · published 2025-12-21

Authentication bypass in WP Affiliate Disclosure (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Vulnerability in mojofywp WP Affiliate Disclosure wp-affiliate-disclosure.This issue affects WP Affiliate Disclosure: from n/a through 1.2.6.

NVD CVE-2023-47232Patchstack advisory

medium 5.4 CVE-2023-52178 · published 2024-01-05

Stored cross-site scripting (XSS) in WP Affiliate Disclosure (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MojofyWP WP Affiliate Disclosure allows Stored XSS.This issue affects WP Affiliate Disclosure: from n/a through 1.2.7.

NVD CVE-2023-52178Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Affiliate Disclosure vulnerability status badge
<a href="https://laskyr.com/plugins/wp-affiliate-disclosure"><img src="https://laskyr.com/plugins/wp-affiliate-disclosure/badge.svg" alt="WP Affiliate Disclosure vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit