Skip to content
Laskyr

Plugins · wp-accessibility-helper · data as of 2026-11-04

Is WP Accessibility Helper (WAH) safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.6.7)

As of 2026-11-04. 6 issues are on record for older versions; version 0.6.7 or newer fixes all of them that state a fix.

Latest version
0.6.7
Last updated
2026-09-02
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Short Description WP Accessibility Helper helps solve accessibility problems — by Alex Volkov

What to do

  1. Update to the latest version (0.6.7). Anything older than 0.6.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-accessibility-helper --field=version shows what you run; wp plugin update wp-accessibility-helper updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24537 · published 2026-07-23

Cross-site request forgery (CSRF) in WP Accessibility Helper (WAH) (0.6.6 and older)

Affected
0.6.6 and older
Fixed in
0.6.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in WP Accessibility Helper (WAH) <= 0.6.6 versions.

NVD CVE-2026-24537Patchstack advisory

medium 4.3 CVE-2023-41869 · published 2024-12-13

Missing authorization check in WP Accessibility Helper (WAH) (0.6.2.4 and older)

Affected
0.6.2.4 and older
Fixed in
0.6.2.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Alex Volkov WP Accessibility Helper (WAH) allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Accessibility Helper (WAH): from n/a through 0.6.2.4.

NVD CVE-2023-41869Patchstack advisory

medium 5.3 CVE-2024-37926 · published 2024-11-01

Missing authorization check in WP Accessibility Helper (WAH) (0.6.2.9 and older)

Affected
0.6.2.9 and older
Fixed in
0.6.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Alex Volkov WP Accessibility Helper (WAH) allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WP Accessibility Helper (WAH): from n/a through 0.6.2.9.

NVD CVE-2024-37926Patchstack advisory

medium 4.3 CVE-2024-5987 · published 2024-08-29

Missing authorization check in WP Accessibility Helper (WAH) (0.6.2.8 and older)

Affected
0.6.2.8 and older
Fixed in
0.6.2.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Accessibility Helper (WAH) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_contrast_variations' and 'save_empty_contrast_variations' functions in all versions up to, and including, 0.6.2.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit or delete contrast settings. Please note these issues were patched in 0.6.2.8, though it broke functionality and the vendor has not responded to our follow-ups.

NVD CVE-2024-5987Wordfence advisoryCode change (fix)

high 8.8 CVE-2024-31423 · published 2024-06-09

Missing authorization check in WP Accessibility Helper (WAH) (0.6.2.5 and older)

Affected
0.6.2.5 and older
Fixed in
0.6.2.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Alex Volkov WP Accessibility Helper (WAH).This issue affects WP Accessibility Helper (WAH): from n/a through 0.6.2.5.

NVD CVE-2024-31423Patchstack advisory

medium 6.1 CVE-2022-0150 · published 2022-02-28

Reflected cross-site scripting (XSS) in WP Accessibility Helper (WAH) (older than 0.6.0.7)

Affected
older than 0.6.0.7
Fixed in
0.6.0.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The WP Accessibility Helper (WAH) WordPress plugin before 0.6.0.7 does not sanitise and escape the wahi parameter before outputting back its base64 decode value in the page, leading to a Reflected Cross-Site Scripting issue

NVD CVE-2022-0150WPScan advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Accessibility Helper (WAH) vulnerability status badge
<a href="https://laskyr.com/plugins/wp-accessibility-helper"><img src="https://laskyr.com/plugins/wp-accessibility-helper/badge.svg" alt="WP Accessibility Helper (WAH) vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit