Plugins · wp-accessibility · data as of 2026-11-04
Is WP Accessibility safe? Known vulnerabilities and latest version
- Latest version
- 2.4.5
- Last updated
- 2026-10-25
- Active installs
- 60,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
WP Accessibility fixes common accessibility issues in your WordPress site. — by Joe Dolson
What to do
- Update to the latest version (2.4.5). Anything older than 2.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-accessibility --field=version shows what you run; wp plugin update wp-accessibility updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2362 · published 2026-02-27
DOM-based cross-site scripting (XSS) in WP Accessibility (2.3.1 and older)
- Affected
- 2.3.1 and older
- Fixed in
- 2.3.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Accessibility plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'alt' attribute of images processed by the "Long Description UI" feature in all versions up to, and including, 2.3.1. This is due to the plugin's JavaScript retrieving the alt attribute using getAttribute() and unsafely concatenating it into innerHTML and insertAdjacentHTML calls without proper sanitization or escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the "Long Description UI" setting to be enabled and set to "Link to description."
NVD CVE-2026-2362Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-25 — latest release on wordpress.org (2.4.5).
- 2026-02-27 — DOM-based cross-site scripting (XSS) disclosed (CVE-2026-2362), fixed in 2.3.4.
Get an email when WP Accessibility has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Accessibility (wp-accessibility) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Joe Dolson (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-accessibility (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-accessibility"><img src="https://laskyr.com/plugins/wp-accessibility/badge.svg" alt="WP Accessibility vulnerability status"></a>