Skip to content
Laskyr

Plugins · wp-404-auto-redirect-to-similar-post · data as of 2026-11-04

Is WP 404 Auto Redirect to Similar Post safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.6)

As of 2026-11-04. 4 issues are on record for older versions; version 1.0.6 or newer fixes all of them that state a fix.

Latest version
1.0.6
Last updated
2025-11-21
Active installs
30,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 5.6+

Automatically Redirect any 404 page to a Similar Post based on the Title Post Type & Taxonomy using 301 or 302 Redirects! — by Konrad Chmielewski

What to do

  1. Update to the latest version (1.0.6). Anything older than 1.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-404-auto-redirect-to-similar-post --field=version shows what you run; wp plugin update wp-404-auto-redirect-to-similar-post updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2025-12037 · published 2026-02-18

Stored cross-site scripting (XSS) in WP 404 Auto Redirect to Similar Post (1.0.5 and older)

Affected
1.0.5 and older
Fixed in
1.0.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP 404 Auto Redirect to Similar Post plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-12037Wordfence advisoryPlugin source

high 7.1 CVE-2024-32559 · published 2024-04-18

Reflected cross-site scripting (XSS) in WP 404 Auto Redirect to Similar Post (1.0.4 and older)

Affected
1.0.4 and older
Fixed in
1.0.5 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hwk-fr WP 404 Auto Redirect to Similar Post allows Reflected XSS.This issue affects WP 404 Auto Redirect to Similar Post: from n/a through 1.0.4.

NVD CVE-2024-32559Patchstack advisory

medium 6.1 CVE-2024-0509 · published 2024-02-05

Reflected cross-site scripting (XSS) in WP 404 Auto Redirect to Similar Post (1.0.3 and older)

Affected
1.0.3 and older
Fixed in
1.0.4 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP 404 Auto Redirect to Similar Post plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘request’ parameter in all versions up to, and including, 1.0.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-0509Wordfence advisoryCode change (fix)

medium 4.8 CVE-2023-40206 · published 2023-09-04

Stored cross-site scripting (XSS) in WP 404 Auto Redirect to Similar Post (1.0.3 and older)

Affected
1.0.3 and older
Fixed in
1.0.4 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in hwk-fr WP 404 Auto Redirect to Similar Post plugin <= 1.0.3 versions.

NVD CVE-2023-40206Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP 404 Auto Redirect to Similar Post vulnerability status badge
<a href="https://laskyr.com/plugins/wp-404-auto-redirect-to-similar-post"><img src="https://laskyr.com/plugins/wp-404-auto-redirect-to-similar-post/badge.svg" alt="WP 404 Auto Redirect to Similar Post vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit