Skip to content
Laskyr

Plugins · wow-elements-addons-for-elementor · data as of 2026-11-04

Is Wow Elements Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.11.7)

As of 2026-11-04. 1 issue is on record for older versions; version 1.11.3 or newer fixes all of them that state a fix.

Latest version
1.11.7
Last updated
2026-08-19
Active installs
50+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

The most powerful free addons & widgets for Elementor. 175+ advanced features for responsive sites. Drag-and-drop, pixel-perfect, mobile friendly. — by Wow Elements

What to do

  1. Update to the latest version (1.11.7). Anything older than 1.11.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wow-elements-addons-for-elementor --field=version shows what you run; wp plugin update wow-elements-addons-for-elementor updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-1641 · published 2026-09-19

Server-side request forgery (SSRF) in Wow Elements Addons for Elementor (1.11.2 and older)

Affected
1.11.2 and older
Fixed in
1.11.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Wow Elements Addons for Elementor plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.11.2. This is due to the plugin passing user-controlled input from the 'Changelog File' setting directly to the wp_remote_get function without adequate validation or sanitization of the URL. This makes it possible for authenticated attackers, with Contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2026-1641Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Wow Elements Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/wow-elements-addons-for-elementor"><img src="https://laskyr.com/plugins/wow-elements-addons-for-elementor/badge.svg" alt="Wow Elements Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit