Skip to content
Laskyr

Plugins · worpit-admin-dashboard-plugin · data as of 2026-11-04

Is iControlWP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.7.2)

As of 2026-11-04. 2 issues are on record for older versions; version 5.5.4 or newer fixes all of them that state a fix.

Latest version
5.7.2
Last updated
2026-10-27
Active installs
900+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.2 · PHP 7.4+

Manage all your WordPress sites in one place - updates, uptime, backups & security. — by Paul

What to do

  1. Update to the latest version (5.7.2). Anything older than 5.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get worpit-admin-dashboard-plugin --field=version shows what you run; wp plugin update worpit-admin-dashboard-plugin updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-34901 · published 2026-06-15

Privilege escalation in iControlWP (5.5.3 and older)

Affected
5.5.3 and older
Fixed in
5.5.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Privilege Escalation in iControlWP <= 5.5.3 versions.

NVD CVE-2026-34901Patchstack advisory

critical 9.8 CVE-2024-13742 · published 2025-01-30

PHP object injection in iControlWP (4.4.5 and older)

Affected
4.4.5 and older
Fixed in
4.5.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The iControlWP – Multiple WordPress Site Manager plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 4.4.5 via deserialization of untrusted input from the reqpars parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.

NVD CVE-2024-13742Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
iControlWP vulnerability status badge
<a href="https://laskyr.com/plugins/worpit-admin-dashboard-plugin"><img src="https://laskyr.com/plugins/worpit-admin-dashboard-plugin/badge.svg" alt="iControlWP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit